Opened 9 years ago

Closed 9 years ago

#6057 closed bug (fixed)

Silence from headphone socket

Reported by: alban Owned by: korli
Priority: normal Milestone: R1
Component: Drivers/Audio/HDA Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking: #6117
Has a Patch: no Platform: All

Description

When I plug headphones into the front socket (pin 27?) the speaker sound is muted as expected. There is no sound from the headphones either though. ( the headphone socket works under inferior operating systems.) Attaching syslog.

hardware: Dell Hybrid 140G.

Attachments (1)

syslog (107.1 KB) - added by alban 9 years ago.
Syslog showing events

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by alban

Attachment: syslog added

Syslog showing events

comment:1 Changed 9 years ago by korli

Component: - GeneralDrivers/Audio/HDA
Owner: changed from nobody to korli

comment:2 Changed 9 years ago by korli

It seems the headphone output isn't unmuted in the code. We only (un)mute the speaker at the moment.

comment:3 Changed 9 years ago by korli

I committed an untested fix in hrev36959. Dunno if you can test it though.

comment:4 Changed 9 years ago by anevilyak

Blocking: 6117 added

(In #6117) Duplicate of #6057.

comment:5 Changed 9 years ago by amonpaike

sorry for duplicated Ticket, i dont see this before. otherwise, i have tested the haiku-nightly-hrev36995-x86gcc4hybrid-raw.tar.xz and dont work.

comment:6 Changed 9 years ago by korli

Please give a try at hrev37012. Thanks!

comment:7 Changed 9 years ago by amonpaike

ok tested on intel 82801H headphones works ! :)

comment:8 Changed 9 years ago by alban

Thanks this is all working fine now,

comment:9 Changed 9 years ago by korli

Resolution: fixed
Status: newclosed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.