Opened 10 years ago

Closed 10 years ago

#6074 closed bug (fixed)

PackageInstaller crashes after installing package

Reported by: richienyhus Owned by: sil2100
Priority: normal Milestone: R1
Component: Applications/PackageInstaller Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: yes Platform: All

Description

While installing Globe Webeditor, PackageInstaller crashes.

http://www.haikuware.com/directory/view-details/development/editors/globe-webeditor

Attachments (2)

gdb-package installer (5.3 KB ) - added by richienyhus 10 years ago.
quick_fix.diff (329 bytes ) - added by sil2100 10 years ago.
fCurrentScript fix

Download all attachments as: .zip

Change History (10)

by richienyhus, 10 years ago

Attachment: gdb-package installer added

comment:1 by sil2100, 10 years ago

Status: newin-progress

I can't seem to reproduce your problem, the package globe_v040.pkg installs without any problems here. When does the PackageInstaller crash in your case? Does it start the installation? If it does, on what file number or installation stage does it crash? Do you run it on a virtual machine or a real computer?

Such information would be most helpful. Thanks.

comment:2 by richienyhus, 10 years ago

It crashed on the "package has been installed" screen.

And this was on a real system (AMD Sempron, KM51G-754).

comment:3 by richienyhus, 10 years ago

I think this can be closed. I've tried again and it installs just fine.

It seemed to crash just as the installtion finished, while also webpositive froze Tracker around about the same time

comment:4 by stippi, 10 years ago

A bug is a bug and doesn't go away when one just closes a ticket. :-) We just need to get to the bottom of it. WebPositive cannot freeze anything, though.

comment:5 by sil2100, 10 years ago

Indeed, this still is a bug. From what I see in the debug output the problem is in the Stop() method - and there indeed is one error in my code there that might possibly make the application crash. The fCurrentScript variable is used in the Stop() code for instance, but it is not initialized to NULL at object construction, so logically, it should crash more often in normal packages (packages with no script files). I'm surprised that I can't reproduce this problem when it's so obvious.

Whether or not it's actually the problem here, I'm attaching the diff since it is a bug anyway.

by sil2100, 10 years ago

Attachment: quick_fix.diff added

fCurrentScript fix

comment:6 by mmlr, 10 years ago

To reproduce such problems more reliably, make use of libroot_debug that includes the debug heap. It will initialize memory to 0xcc and therefore expose problems like these. To run an app with it you can use LD_PRELOAD=libroot_debug.so TheAppInQuestion from the command line.

comment:7 by stippi, 10 years ago

Has a Patch: set

comment:8 by stippi, 10 years ago

Resolution: fixed
Status: in-progressclosed

Probably fixed in hrev36940. Thanks!

Note: See TracTickets for help on using tickets.