Opened 9 years ago

Closed 10 months ago

#6081 closed bug (not reproducible)

Haiku cannot install, and somehow seems to dislike core unlocking...

Reported by: LSS37040 Owned by: nobody
Priority: normal Milestone: R1
Component: System Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I just cannot install Haiku no matter what.

The Haiku R1 Alpha 2 install CD will boot and load, then hang after showing the 4th icon (hard drives). I just don't know why.

What's worse, when I pressed RESET button on my computer and reboot, I found that my CPU is no longer core/L3 unlocked, and I cannot re-unlock it through turning ACC off and then on, unless I clear the CMOS. And still I cannot install Haiku.

Now I just don't know whether Haiku is still incompatible with my hardware, or that whether it's true that Haiku doesn't like ACC and core unlocking, and would revert it during boot process...

This is my computer's hardware list:

Motherboard: ASRock AOD790GX/128M (Socket AM2+, AMD 790GX/SB750 Chipset)

CPU: AMD Athlon II X3 435 @ 2.9GHz (4th core and 6MB L3 unlocked)

RAM: 2x2GB Kingston HyperX DDR2-1066 (Running at 800)

HDD: Seagate ST3160815AS(160GB) and two ST31500341AS(1.5TB each)

Graphics: PowerColor ATI Radeon HD 5770

Change History (8)

comment:1 by stippi, 9 years ago

As to the freeze on the fourth icon, sometimes there are conditions in the ATA bus manager that make a long device detection timeout kick in, I think 30 seconds per device. On one of my computers, I am affected by this problem and it can sit I think 2 minutes or so at the fourth icon befor it continues to boot. Maybe you could try to let it sit for a while to see if it would indeed continue after the timeouts.

As for the core/L3 unlock problem, it deserves it's own bug. I think the ATA timeout issue already has a ticket, if that's indeed what's happening here, so this bug could be changed to refer only this core/L3 unlock thing, whatever it means.

comment:2 by mmlr, 9 years ago

I could imagine that it is an interrupt storm. If so it's possible that it hogs the CPU quite a bit and therefore produces quite a bit of heat that might just kick in some protection mechanism that resets the unlocking as part of some downclocking or similar. Haiku definitely doesn't undo any unlocking or such, so it'd have to be something the firmware or CPU does as a response to what Haiku happens to trigger.

comment:3 by LSS37040, 9 years ago

Recently I replaced my original CPU with a Phenom II X4 945...

But still I cannot install. When I was still using the Athlon II X3 435, the CD boot can go past the fourth icon then freeze. Now with this new Phenom II X4 945 it won't even go past the fourth icon.

Sometimes I waited for several minutes but nothing happens. If I try to press the power button the screen would turn black and shut down, meaning that the system still responds.

Is there any problem with my SATA settings? I use an IDE DVD-RW while using those three SATA hard drives under AHCI. I did try to revert it back to IDE but it still won't go through... so the problem is probably not because of the use of AHCI.

I tried to debug... but the last few lines were like this:

PCI: [dom 0, bus 0] bus 0, device 24, function 3: vendor 1022, device 1023, revision 00

PCI: class_base 06, class_function 00, class_api 00

PCI: vendor 1022: Advanced Micro Devices [AMD]

PCI: device 1203: K10 [Opteron, Athlon64, Sempron] Miscellaneous Control

PCI: info: Bridge (Host bridge)

PCI: line_size 00, latency 00, header_type 00, BIST 00

PCI: ROM base host 00000000, pci 00000000, size 00000000

PCI: cardbus_CIS 00000000, subsystem_id 00000000, subsystem_vendor_id 00000000

PCI: interrupt_line 00, interrupt_pin 00, min_grant 00, max_latency 00

PCI: base reg 0: host 00000000, pci 00000000, size 00000000, flags 00

PCI: base reg 1: host 00000000, pci 00000000, size 00000000, flags 00

PCI: base reg 2: host 00000000, pci 00000000, size 00000000, flags 00

PCI: base reg 3: host 00000000, pci 00000000, size 00000000, flags 00 (hangs here)

In fact, the lines before them on my screen were talking about some other components of the CPU, and all of them have 6 registers (reg 0 - reg 5). Not sure why it hangs here, though.

EDIT: As tested. Forcing the system to boot with a single core will make it go past the fourth icon and then freezes. However, the last lines of the debug log are still the same as the aforementioned ones.

Last edited 9 years ago by LSS37040 (previous) (diff)

comment:4 by stargatefan, 9 years ago

go into your BIOS and turn the plug and play OS option Off.

in reply to:  4 comment:5 by LSS37040, 9 years ago

Plug and Play OS option?

My AOD790GX/128M seems kinda too new for that option to be available in BIOS. And that thing uses AMI BIOS and I'm not too familiar with that.

I only remember such options in old motherboards.

Well, looks like I have to wait till this OS is at least ready for regular usage then.

PS, I also have to comment about a problem about its boot loader. When I tested it on an older computer of mine which I can install it on, the boot manager only detects the first hard drive, while I usually install such OS on second hard disk and it cannot detect it.

comment:6 by waddlesplash, 11 months ago

Still an issue?

comment:7 by LSS37040, 10 months ago

I think it's time closing the issue as I no longer have the hardware configuration I used to report the issue anymore to test this, but someone who still runs a core-unlocked AM2+/AM3 system is welcome to test and reach a formal conclusion.

Yeah, it's been over 9 years since last time I actually tried Haiku OS and I almost forgot about this place. Still, glad to hear that the OS finally reached Beta after this many years. I think I might give it a try again, though most likely I'd still have to use a VM to abstract any unsupported hardware (such as CPU/Memory configuration, chipsets, and especially discrete video and audio cards whose support on such OSes is quite unlikely).

comment:8 by waddlesplash, 10 months ago

Resolution: not reproducible
Status: newclosed

OK, closing.

I think you would be surprised how much hardware we actually support now. Pretty much most machines I've tried Haiku on have at least booted, and ethernet worked, and often times WiFi has too. There are very few "boot doesn't work" tickets remaining, and the ones that are, are mostly USB3-related...

Note: See TracTickets for help on using tickets.