Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#6095 closed bug (invalid)

system freezes completely while loading desktop

Reported by: tb Owned by: korli
Priority: normal Milestone: R1
Component: Drivers/Audio/auich Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I should have tried the livecd before installing, but didn't. The livecd does work fine on a different computer. The installer worked fine.

When running from cdrom, the deskbar, the three leftmost desktop icons and the background image appear, then the system freezes. I cannot get into KDL. I can move the mouse around before the freeze.

When running from disk, the deskbar appears, a faint click is heard from the speakers (maybe also when running from cdrom, but that drive is too noisy), then the system freezes. Again I cannot get into KDL.

When enabling safe mode and running from disk, the system seems frozen for a second after the desktop loads, then appears to work fine. Then I can get into KDL. No clicks this way.

Other boot options don't seem to matter. I tried the following combinations:

  • all in safe mode menu (works)
  • all in safe mode menu except safe mode (doesn't work)
  • only safe mode itself (works)

This is a relatively old laptop with unsurprising hardware and enough memory (512M), see attachments for details.

Attachments (4)

listdev.txt (2.9 KB) - added by tb 9 years ago.
listimage_grep_drivers.txt (1.4 KB) - added by tb 9 years ago.
listusb.txt (5.2 KB) - added by tb 9 years ago.
media_server.JPG (412.0 KB) - added by tb 9 years ago.

Download all attachments as: .zip

Change History (20)

Changed 9 years ago by tb

Attachment: listdev.txt added

Changed 9 years ago by tb

Attachment: listimage_grep_drivers.txt added

Changed 9 years ago by tb

Attachment: listusb.txt added

comment:1 Changed 9 years ago by tb

Forgot to write these obvious(?) things:

Ctrl-alt-del also doesn't work.

The system info in the attachments was gathered while in safe mode, with an usb drive attached that wasn't attached while examining the behavior of the bug.

comment:2 Changed 9 years ago by anevilyak

Does disabling ACPI in the boot loader menu make any difference?

comment:3 in reply to:  2 Changed 9 years ago by tb

Replying to anevilyak:

Does disabling ACPI in the boot loader menu make any difference?

Just ACPI disabled: freeze Both ACPI and APM disabled: freeze

comment:4 Changed 9 years ago by luroh

If you boot in safe mode and then manually start the media_server, does that cause a freeze?

comment:5 Changed 9 years ago by luroh

...and while you're at it; if starting media_server doesn't cause a freeze, try starting net_server.

Changed 9 years ago by tb

Attachment: media_server.JPG added

comment:6 Changed 9 years ago by tb

Component: - GeneralServers/media_server
Owner: changed from nobody to axeld

media_server does indeed cause a freeze. I attached a photo of its output (dumping it to a file on a usb stick didn't work) - there were a few more "couldn't find ..." lines and I think those were different but I couldn't read them that quickly.

I just remembered something: when I first installed Linux on this laptop, I had to disable the kernel module for the modem to make the sound work. Or something like that. It's years ago.

I'll paste the hardware info of the sound & modem here so it will show up in search, the rest of the hardware info is still in listdev.txt.

device Communication controller (Modem, Generic) [7|3|0] vendor 8086: Intel Corporation device 24c6: 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller device Multimedia controller (Multimedia audio controller) [4|1|0] vendor 8086: Intel Corporation device 24c5: 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller

comment:7 Changed 9 years ago by cipri

it seems it's a duplicate of ticket #4491 (i have the same problem, with the same hardware :-) )

comment:8 in reply to:  7 Changed 9 years ago by tb

Replying to cipri:

it seems it's a duplicate of ticket #4491 (i have the same problem, with the same hardware :-) )

I agree, it probably is the same bug. I moved that link to auich out of the way as described in #4491, and the system doesn't freeze anymore.

comment:9 Changed 9 years ago by cipri

one alternative is... to install OSS. so with OSS i have now Sound :-)

download oss from the following link, and then unzip the file to: /boot

http://www.haikuware.com/directory/view-details/drivers/audio/open-sound-system-oss

comment:10 Changed 9 years ago by korli

Component: Servers/media_serverDrivers/Audio
Owner: changed from axeld to korli

comment:11 Changed 9 years ago by korli

A syslog would definitely be useful. Thanks in advance.

comment:12 in reply to:  11 Changed 9 years ago by tb

Replying to korli:

A syslog would definitely be useful. Thanks in advance.

Is there a way to make Haiku log to a file on disk rather than logging to RAM and then copying from RAM to a file after a reset? I only have a power button (which wipes the RAM), no reset button. Also, no serial port.

Or did you want a syslog from safe mode (where the crash doesn't happen)? I'll put the driver back in place and make that...

comment:13 Changed 9 years ago by tb

OK now this is weird...

I put the driver back, and immediately the system froze. I rebooted, and now the system didn't freeze (like in #4491 ?). So I decided to do a clean reinstall. The system did again freeze on the first boot from disk. I restarted it into safe mode, and... no syslog??? /var is empty and /boot/common/var doesn't even exist. So no syslog.

Perhaps it froze before some initialization was finished, so I do another clean reinstall and this time boot in safe mode the first time. Again, no syslog.

So I try the livecd in safe mode instead... /var/log and /boot/common/var/log now exist, but syslog doesn't.

I'm afraid I won't be able to post a syslog this way!

comment:14 Changed 9 years ago by tb

Unfortunately I won't be able to test any possible fixes for this bug - the laptop died.

comment:15 Changed 9 years ago by korli

Resolution: invalid
Status: newclosed

RIP. Thanks for the feedback.

comment:16 Changed 8 years ago by diver

Component: Drivers/AudioDrivers/Audio/AUICH
Note: See TracTickets for help on using tickets.