Opened 9 years ago

Closed 2 years ago

Last modified 15 months ago

#6096 closed bug (invalid)

"unhandled pagefault in kernel space" when booting anyboot from CD

Reported by: jahaiku Owned by: nobody
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

This is a gcc4 build of hrev36922 as anyboot burned and booted from CD on real hardware. I get this error on 3 different machines with different network hardware. If I boot the CD in qemu it is working - why? I have seen a timeout error somewhere in the kdebugger output, but do not know how I get it again. Is it possible, that booting from CD is to slow?

Attachments (1)

anyboot_CD_r36922.jpg (177.8 KB ) - added by jahaiku 9 years ago.

Download all attachments as: .zip

Change History (10)

by jahaiku, 9 years ago

Attachment: anyboot_CD_r36922.jpg added

comment:1 by jahaiku, 9 years ago

Component: - GeneralSystem/Kernel
Owner: changed from nobody to axeld
Platform: Allx86

I have tried to boot the same anyboot image, which is failing when booted from CD, written to an USB-Stick and there I get no error. So it looks like only booting anyboot from CD is triggering this error.

comment:2 by jahaiku, 9 years ago

I have retested this again on some different Hardware and I still get this error in the Network-Hardware-Driver needed for the Hardware (nforce, atheros, realtek). If I am able to disable all networking devices in the Bios - then I can boot.

comment:3 by scottmc, 8 years ago

Can you recheck this with a recent Haiku build?

comment:4 by scottmc, 8 years ago

Blocking: 7665 added

in reply to:  3 comment:5 by jahaiku, 8 years ago

Replying to scottmc:

Can you recheck this with a recent Haiku build?

I have rechecked with gcc4 build of hrev42125 with no change. I get exactly the same error.

comment:6 by luroh, 7 years ago

Looks a lot like #8684, which was fixed the other day. Please give R1 Alpha 4.1 a try.

comment:7 by axeld, 2 years ago

Owner: changed from axeld to nobody
Status: newassigned

comment:8 by waddlesplash, 2 years ago

Resolution: invalid
Status: assignedclosed

No reply in 5 years from luroh's request to retest; closing due to no response.

comment:9 by waddlesplash, 15 months ago

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.