Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6137 closed bug (fixed)

PANIC on boot with intel gfx

Reported by: oxoocoffee Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Graphics/intel_extreme Version: R1/Development
Keywords: Intel gfx kernel panic Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I just tried booting haiku-nightly-hrev37006-x86gcc4hybrid-anyboot.zip and I ma getting is kernel panic. Please see attached serial log.

Attachments (1)

HaikuCrash.log (30.0 KB) - added by oxoocoffee 9 years ago.
Serial log crash

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by oxoocoffee

Attachment: HaikuCrash.log added

Serial log crash

comment:1 Changed 9 years ago by anevilyak

This looks to have been caused by hrev36999, which appears to not take into account that a NULL pointer can be passed in for the physical base parameter.

comment:2 Changed 9 years ago by anevilyak

Hopefully fixed in hrev37016, please test.

comment:3 Changed 9 years ago by oxoocoffee

After building hrev37016 I can verify that this is fixed now. Thank you

comment:4 Changed 9 years ago by anevilyak

Resolution: fixed
Status: newclosed

comment:5 Changed 9 years ago by anevilyak

Component: System/KernelDrivers/Graphics/intel_extreme
Version: R1/alpha2R1/Development
Note: See TracTickets for help on using tickets.