Opened 10 years ago

Closed 6 weeks ago

Last modified 4 weeks ago

#6138 closed bug (fixed)

rare segfault when exitting IFS screensaver

Reported by: Ziusudra Owned by: korli
Priority: normal Milestone: R1/beta2
Component: Add-Ons/Screen Savers Version: R1/alpha2
Keywords: screen_blanker Cc: stippi
Blocked By: Blocking:
Platform: All

Description

r1a2/nvidia/desktop and 37010/vesa/laptop

Seems to happen ... probably less than 10% of the time. Also happens when using preflet's test button. Have yet to reproduce with other screen savers.

Attachments (3)

IFS-screen_blanker-gdb.txt (4.5 KB ) - added by Ziusudra 10 years ago.
flurry-gdb.txt (4.7 KB ) - added by Ziusudra 8 years ago.
screen_blanker-854-debug-04-03-2014-23-43-03.report (10.5 KB ) - added by jscipione 6 years ago.
Crash report on hrev46971

Download all attachments as: .zip

Change History (10)

by Ziusudra, 10 years ago

Attachment: IFS-screen_blanker-gdb.txt added

comment:1 by korli, 10 years ago

Resolution: fixed
Status: newclosed

Fixed in hrev37035.

comment:2 by Ziusudra, 10 years ago

Resolution: fixed
Status: closedreopened

Although it seems to be rarer, I've gotten this a couple of times on nightly 37174 gcc2hybrid with the same backtrace.

comment:3 by Ziusudra, 10 years ago

Still happening on hrev39748 gcc2h hardware though only 1-2% of the time.

by Ziusudra, 8 years ago

Attachment: flurry-gdb.txt added

comment:4 by Ziusudra, 8 years ago

Still happens with IFS on about 1 in 50 attempts. Also seen with Flurry after about 50 attempts, bt attached.

Oops, should mention that this is on r1a4 (not 4.1.)

Last edited 8 years ago by Ziusudra (previous) (diff)

by jscipione, 6 years ago

Crash report on hrev46971

comment:5 by Ziusudra, 6 weeks ago

Cannot reproduce on R1/beta2 hrev54154+31 on same hardware. Suggest closing ticket.

Last edited 6 weeks ago by Ziusudra (previous) (diff)

comment:6 by diver, 6 weeks ago

Resolution: fixed
Status: reopenedclosed

comment:7 by nielx, 4 weeks ago

Milestone: R1R1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

(final time)

Note: See TracTickets for help on using tickets.