Opened 9 years ago

Closed 10 months ago

#6176 closed bug (fixed)

TalkBox app. doesn't run

Reported by: Meanwhile Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking: #2871
Has a Patch: no Platform: All

Description

TalkBox application (http://haikuware.com/directory/view-details/multimedia/audio/utilities/talkbox) doesn't run on hrev36930, while it's been reported to run on Haiku alpha 1.
Running it from Terminal with 'beoscompatibility' installed showed up possible useful info, but only the very first time, so I missed it and can't add it here...

Attachments (1)

Archive (1).zip (1.6 KB ) - added by kvdman 9 years ago.

Download all attachments as: .zip

Change History (4)

by kvdman, 9 years ago

Attachment: Archive (1).zip added

comment:1 by pulkomandy, 5 years ago

TalkBox comes with a bundled Festival which hardcodes paths to various things, making it difficult to run on a current system. Writing a recipe for a current version of Festival and packaging it would solve at least part of the problem: http://www.cstr.ed.ac.uk/projects/festival/

the TalkBox itself is just an xicon script, so it can be modified with a text editor if it needs to be fixed. Same for ChangeVoices. They both use the "saytext" command from festival to actually do things.

comment:2 by pulkomandy, 5 years ago

Blocking: 2871 added

(In #2871) There is no binary there, it's just an xicon script. Closing as duplicate of #6176, a better port of Festival is needed, or this could easily be modified to use espeak instead.

comment:3 by waddlesplash, 10 months ago

Resolution: fixed
Status: newclosed

There is now a proper port of Festival.

Note: See TracTickets for help on using tickets.