Opened 9 years ago

Closed 12 months ago

#6240 closed bug (duplicate)

PDF printing delivers poor quality

Reported by: axeld Owned by: stippi
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/alpha2
Keywords: Cc: phoudoin
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When exporting a PDF using our PDF printer, the font quality is noticeably bad. I guess this is a problem with our font management in the app_server, but I'm not entirely sure whether it's because of something not yet implemented, or because there is something wrong.

Furthermore, some non-ASCII characters (like the EUR currency symbol) is incorrect with some fonts (Arial, copied from a Windows installation).

At first, I assumed that our "Deja Vu Sans" font is to blame for this, but since it didn't get much better with the Arial font, I must assume an app_server problem instead.

Change History (4)

comment:1 by phoudoin, 9 years ago

Is font embebded into the PDF? IIRC, there is a window to select which font should be embebded, by default they're not and font substitution is done instead. Does the font quality is bad under every PDF readers, or only somes?

Otherwise, it could be related to the font enconding declarations done via PDFLib-provided files, hosted under src/add-ons/print/drivers/pdf/encoding. Maybe they're obsolete, I confess I've never search how it was supposed to works.

Or maybe they're just not anymore located under /boot/home/config/settings/PDF Writer/ folder, and are not found since ;-)

http://dev.haiku-os.org/browser/haiku/trunk/src/add-ons/print/drivers/pdf/source/PDFWriter.cpp#L347

comment:2 by phoudoin, 9 years ago

Cc: phoudoin added

comment:3 by vidrep, 3 years ago

I have had several instances where a PDF could not be printed properly due to a missing font. Usually downloading the required font and placing it in /boot/home/config/non-packaged/data/fonts/ resolved the issue.

comment:4 by waddlesplash, 12 months ago

Resolution: duplicate
Status: newclosed

Duplicate of an issue already migrated to PDFWriter's new home.

Note: See TracTickets for help on using tickets.