Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#626 closed bug (fixed)

[Menu] crazy resizing on start

Reported by: diver Owned by: jackburton
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

If you launch Menu pref it's window will begin to resize horizontally forever! Tested with hrev17577 under vmware.

Change History (12)

comment:1 by diver, 13 years ago

Oops not forever :-) but very long...

comment:2 by axeld, 13 years ago

Cc: axeld@… added

comment:3 by axeld, 13 years ago

I guess this is related to the BMenuBar work-around I made, in combination with some weird bug in Menu. Maybe we should revert my change and search for a better solution. Stefano?

comment:4 by axeld, 13 years ago

Owner: changed from axeld to jackburton

comment:5 by jackburton, 13 years ago

Yes, I'd go for it. Especially because it also causes another bug in deskbar: Try to move the deskbar from the compressed position in the right top corner to the expanded horizontally position: the team items will be shrinked, until you start or kill some apps. BTW, I tried reverting your change and resizing MediaPlayer; its MenuBar seemed to resize as it should, except it was (temporarily) filled with black before being redrawn correctly. So I can't reproduce the problem you fixed with that change. But since I've done some other changes locally, maybe it's gone in another way.

comment:6 by axeld, 13 years ago

Great, that's exactly what happens on BeOS, too - the black background is there for a flash of a second and then it's drawn correctly. Can you please revert my change then? (and commit whatever fixes you have waiting once there are done?) :-)

comment:7 by jackburton, 13 years ago

Status: newassigned

comment:8 by jackburton, 13 years ago

Will do :)

comment:9 by lothalev@…, 13 years ago

Still happening in rev17592 build for vmware. Not crashing the system though

comment:10 by jackburton, 13 years ago

Resolution: fixed

comment:11 by jackburton, 13 years ago

Status: assignedclosed

comment:12 by jackburton, 13 years ago

Fixed

Note: See TracTickets for help on using tickets.