Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#6319 closed bug (fixed)

Problem with multi core CPU

Reported by: Miroslav-Stimac Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/alpha2
Keywords: multi core cpu, alpha 2, installation, problem Cc: Miroslav.Stimac@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Hello,

I tried to install Haiku R1 Alpha 2 on a notebook and I failed. I used the boot CD. The MD5 is OK.

Notebook: Samsung R40 Plus Intel Core Duo CPU 2 GB RAM ATI XPRESS Radeon 1250

The system fails to boot from the boot CD. The boot screen loads and progeresses until the last icon (the rocket). Sometimes even the blue desktop screen appaers (but it is empty). After that nothing happens. There is no error message. It seems that the system simply stops.

The R1 Alpha 1 works fine on this notebook.

Today I found the source of the problem.

When I deactivate the second CPU core in the BIOS of the notebook, then I can start and use Haiku Alpha 2.

By the way, I have the same problem with the newest nightly build.

Please note that I tried all options in the safe mode and I deactivated the power management, the LAN, the wireless functions and almost anything that I could find in the BIOS configuration and the Haiku safe boot menu. Nothing helped.

Only when I deactivate the second CPU core, then Haiku Alpha 2 runs, even when all the other features are activated.

Why is this so?

The Haiku Alpha 1 version runs wonderful on this notebook, even with both CPU cores.

What was changes between Alpha 1 and Alpha 2 that could cause such a problem?

Best wishes, Miroslav

Change History (12)

comment:1 by tonestone57, 9 years ago

You need to include syslog for any developer to try to fix the problem. The syslog should be from your *not* booting system. It will show what is going on.

There is way to save syslog to file for non-booting system. Read here: http://dev.haiku-os.org/wiki/ReportingBugs#Syslog

Edit: Go into safe-mode by holding down SHIFT key (or by pressing SPACEBAR).

Last edited 9 years ago by tonestone57 (previous) (diff)

comment:2 by anevilyak, 9 years ago

If anything I would've thought ACPI might be a possible culprit, but since you claim to have tried disabling that in safe mode already it seems not...syslog would indeed be helpful.

comment:3 by tqh, 9 years ago

It would be good if you can test older builds between alpha 1 and and alpha 2 to at least find a clue when this started. Usually to track down this kind of issues binary search is used:

  • Pick a build in between the last known working version and the broken one.
  • If it works pick the one in the middle of the new working version and the broken one
  • If it doesn't work pick the one in between the old working version and the new broken one.

Continue and narrow down until you only have one or a few versions which it was introduced in. This would help a lot.

comment:4 by Miroslav-Stimac, 9 years ago

Hello,

Thank you very much for your response.

Now I tried it with the nightly build hrev37453 GCC2HYBRID. The system stops when the second CPU core is enabled. Meanwhile I enabled on screen log output while booting. The system stops always at the same line.

publish device: node 0x8226ed70, path power/embedded_controller/0, module drivers/power/acpi_embedded_controller/device_v1 ahci: ahci_supports_device

When starting from the boot CD of Alpha 2, sometimes it runs a bit longer and stops a few seconds later, for example when the screen for the language selection appears.

Please note that I used the safe mode and I disabled all features except video mode. Among others, I also disabled ACPI in the Safe Mode Options of the Haiku boot Loader and I disabled the CPU Power Saving Mode in my BIOS configuration.

The only option that helped was to disable the second CPU core in the BIOS, but this is not good because of performance. However, when the second CPU core is disabled, the system boots without any noticeable problems and I can use the system.

As I mentioned, the Haiku Alpha 1 version worked with both CPU cores without any boot problems.

Best wishes, Miroslav

comment:5 by tqh, 9 years ago

Second cpu is initialized after acpi_embedded_controller iirc so it seems like either enabling second cpu or some driver halts progress. I don't think ACPI is involved. Could you try what I mention in comment:3 it will probably be the fastest way to give us enough details to track down and fix this.

comment:6 by Miroslav-Stimac, 9 years ago

Hello,

thank you for your answer. Now I am trying to check the older versions, but this may take much time. My USB stick seems not to be bootable and my CD RW discs are old and only quadro speed. Therefore it may take much time. If I find any results, I will inform you.

Regards, Miroslav

comment:7 by Miroslav-Stimac, 9 years ago

Hello,

Meanwhile I found the last working version. It was the last nightly build before Alpha 2 was published. The nightly build hrev36263 from 14th April 2010 works. Alpha 2 was published on 9th May 2010 and does not work with two CPU cores on my notebook. What was changed between the nightly build hrev36263 and the Alpha 2 release?

Best wishes, Miroslav

comment:8 by Coldfirex, 9 years ago

Miroslav: Would you mind testing again with a more recent nighlty build?

comment:9 by Miroslav-Stimac, 9 years ago

Hello Coldfirex,

Now it works with both CPU cpres! I tested the newst Haiku nightly build hrev39648 Gcc2 Hybrid with exactly the same hardware. Thank you very much! I am very happy!!!

Sadly, now it does not want to boot without disabling ACPI in the safe boot settings. In past it booted without disabling it. However, this is no serious problem for me. It is great that both CPU cores work now.

Thank you very much! We can close this ticket.

Regards, Miroslav Stimac

comment:10 by Miroslav-Stimac, 9 years ago

By the way, how can I close it? It seems that I do not have the permissions to close the ticket.

comment:11 by luroh, 9 years ago

Resolution: fixed
Status: newclosed

Thanks for the feedback, please file a separate ticket for your ACPI problem if you can't find a matching one.

comment:12 by Miroslav-Stimac, 8 years ago

Hello,

I downloaded the R1 Alpha 3 CD Image and tried to install in on my notebook. Now I have the same problem as I reported about one year ago in this ticket.

I still have the same hardware.

What did happen? Why does the Alpha 3 not work with both cores on my notebook? Had been the old bug reimplemented? ;-)

On my notebook I have an older version installed: Haiku GCC4 Hybrid, Revision 39771. Dual core works without any problems with this old version!

I know that my notebook has problems with Haiku regarding ACPI or APM and therefore I disable them. But Haiku still fails to boot if I do not disable the dual core support in the BIOS. Disabling any other features in the boot menu does not help. Usinf fail safe mode or fail safe video resolution has no effect, too. The problem seems to be exactly the same one as the one that I described in the ticket. Therefore I would recommend to reopen it.

Best wishes, Miroslav Stimac

P.S.: I tried the latest nightly builds: haiku-nightly-hrev41539-x86gcc4hybrid-cd.tar.xz and haiku-nightly-hrev41539-x86gcc2hybrid-cd.tar.xz ==> The same problem. I will test older versions, but this will take some time. It is midnight now, so I will have to go to bed. :-)

Note: See TracTickets for help on using tickets.