Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#639 closed bug (fixed)

[Deskbar] new replicants are incorrectly positioned

Reported by: johndrinkwater Owned by: sikosis
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc: diver
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Currently there are problems with deskbar icons, but I believe this is unrelated. No matter how many icons I have, like ProcessController, Media, etc, Pulse always overlaps (drawn on top of) the top left item.

Change History (11)

comment:1 Changed 13 years ago by jackburton

Does it move to the correct position if you drag around the deskbar ?

comment:2 Changed 13 years ago by johndrinkwater

Summary: [Pulse] Overlaps other icons in deskbar mode[Deskbar] new replicants are incorrectly positioned

comment:3 Changed 13 years ago by johndrinkwater

Yes, it does. After further testing, it is the all encompassing bug you'd mentioned earlier in #haiku. (I failed to see it with PC because it restarts Deskbar(?))

New bug description: When an new replicant is added to Deskbar, it appears at the start of the list of icons, whether or not the list is empty. Replicants are correctly repositioned once Deskbar has 'moved' its shelf.

comment:4 Changed 13 years ago by diver

Cc: diver added

comment:5 Changed 13 years ago by axeld

Component: ApplicationsKits

comment:6 Changed 13 years ago by korli

Well, if it doesn't happen on R5, it could very well be a problem in our BShelf implementation.

comment:7 Changed 13 years ago by koki@…

(In reply to comment #3)

Well, if it doesn't happen on R5, it could very well be a problem in our BShelf implementation.

I can confirm this bug (on build 17778).

comment:8 Changed 13 years ago by jackburton

Just a thought: could this depend on missing/wrongly initialized archiving flags in BView ? At least, I think the B_VIEW_FRAME_BIT should be set when MoveBy/MoveTo are called.

comment:9 Changed 13 years ago by axeld

Resolution: fixed

comment:10 Changed 13 years ago by axeld

Status: newclosed

comment:11 Changed 13 years ago by axeld

Fixed in hrev18354, the problem was BShelf not calling CanAcceptReplicantView() in AddReplicant.

Note: See TracTickets for help on using tickets.