Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#647 closed bug (fixed)

[kernel] kdl on kernel_x86 double click

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Try to double click /boot/beos/system/kernel_x86. It brings me to kdl with r 17653 under vmware. back trace will follow.

Attachments (2)

kdl_.PNG (34.6 KB ) - added by diver 13 years ago.
kdl
kdl_2.PNG (24.3 KB ) - added by diver 13 years ago.
back trace 2

Download all attachments as: .zip

Change History (14)

by diver, 13 years ago

Attachment: kdl_.PNG added

kdl

comment:1 by axeld, 13 years ago

I can't reproduce this. Does it happen every time you're doing it?

comment:2 by diver, 13 years ago

I now tested it on real hardware with hrev17679 and get the same crash. What i've done: double clicked zbeos and then Proceed button double clicked runtime_loader and then Proceed button double clicked kernel_x86 and went to kdl Hope this could help.

by diver, 13 years ago

Attachment: kdl_2.PNG added

back trace 2

comment:3 by axeld, 13 years ago

Okay, I could reproduce this now: when you first launch "runtime_loader", and then the kernel, the page fault occurs. I wonder why you get the "This file is mistakenly .." - "Proceed" requester; you shouldn't get that one (and I don't get it over here, running Haiku natively).

comment:4 by axeld, 13 years ago

Great! Thanks Diver - that's the long searched VM bug, and now it's 100% reproducible (bug in reference counting) :-)

BTW I have the "This file is mistakenly marked as executable" alert from Tracker now, too. Will look into this afterwards, if it stays there.

comment:5 by axeld, 13 years ago

Status: newassigned

comment:6 by axeld, 13 years ago

Resolution: fixed

comment:7 by axeld, 13 years ago

Fixed in hrev17692. Looking into that Tracker thing next...

comment:8 by axeld, 13 years ago

Status: assignedclosed

comment:9 by diver, 13 years ago

(In reply to comment #7)

Fixed in hrev17692. Looking into that Tracker thing next...

Great! Did you fix that Tracker thing?

comment:10 by axeld, 13 years ago

It is, since hrev17708 - thanks for the reminder :-)

comment:11 by diver, 13 years ago

(In reply to comment #9)

It is, since hrev17708 - thanks for the reminder :-)

You forgot about zbeos...

comment:12 by axeld, 13 years ago

No, zbeos is really not an (ELF) application, and its permissions don't matter at all. It's the same on BeOS, btw.

Note: See TracTickets for help on using tickets.