Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#646 closed bug (fixed)

[emuxki] doesn't let haiku to boot

Reported by: diver Owned by: korli
Priority: blocker Milestone: R1
Component: System/Kernel Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Haiku freeze on load, after app_server start if i plug my Audigy in. It doesn't happened 2 weeks ago. So hrev17627 could be a problem! Isn't media_server should take care of this if sound driver have a bug? This is what microkernel is for, right? :-)

Change History (15)

comment:1 by diver, 13 years ago

Summary: [emuxki] freeze haiku in start[emuxki] doesn't let haiku to boot

comment:2 by jackburton, 13 years ago

Except haiku isn't a microkernel

comment:3 by korli, 13 years ago

It's true I enabled MIDI in emuxki and it could be a problem. Which revision did you test with ?

comment:4 by diver, 13 years ago

Tested with hrev17661.

comment:5 by korli, 13 years ago

Could you try to deactivate MIDI in emuxki.h ?

comment:6 by diver, 13 years ago

(In reply to comment #4)

Could you try to deactivate MIDI in emuxki.h ?

If you tell me how to do it ;-)

comment:7 by korli, 13 years ago

Have a look here : http://svn.berlios.de/viewcvs/haiku/haiku/trunk/src/add- ons/kernel/drivers/audio/emuxki/emuxki.h?rev=17627&hrev1=17105&hrev2=17627

comment:8 by diver, 13 years ago

(In reply to comment #6)

Have a look here : http://svn.berlios.de/viewcvs/haiku/haiku/trunk/src/add- ons/kernel/drivers/audio/emuxki/emuxki.h?rev=17627&hrev1=17105&hrev2=17627

Yes, this seems to fix the problem. Now i can boot just fine on real hardware with installed Audigy.

comment:9 by korli, 13 years ago

Status: newclosed

comment:10 by korli, 13 years ago

MIDI is disabled again for the time being (17680). Diver, you don't have a serial log btw ?

comment:11 by korli, 13 years ago

Resolution: fixed

comment:12 by diver, 13 years ago

Well this is getting really strange now. I changed midi 0 to midi 1 and it still boots. This bug seems to be invalid. Should we close it?

comment:13 by korli, 13 years ago

I asked Greg Crain to have a look. If there is no problem on his side, we'll enable it again.

comment:14 by korli, 13 years ago

I reenabled MIDI in revision 17720 (for Haiku only)

comment:15 by korli, 13 years ago

Cc: marcus@… removed
Note: See TracTickets for help on using tickets.