Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6521 closed bug (fixed)

Page fault in recent gcc4-hyrbrid images on boot with intel wifi 2200

Reported by: kallisti5 Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet/Wireless Version: R1/Development
Keywords: kdl setwep wifi wireless Cc: andrewbachmann, luroh
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Recent nightly images have begun page-faulting on boot due to iprowifi2200. (tested hrev38414, hrev38383)

see attached images for KDL

Attachments (2)

IMG_20100828_175641.jpg (244.7 KB ) - added by kallisti5 9 years ago.
top of kdl
IMG_20100828_175648.jpg (287.0 KB ) - added by kallisti5 9 years ago.
bottom of kdl

Download all attachments as: .zip

Change History (15)

by kallisti5, 9 years ago

Attachment: IMG_20100828_175641.jpg added

top of kdl

by kallisti5, 9 years ago

Attachment: IMG_20100828_175648.jpg added

bottom of kdl

comment:1 by kallisti5, 9 years ago

confirmed this still exists on hrev38513.

comment:2 by kallisti5, 9 years ago

I ripped out the iprowifi drivers from the boot disk and tried again, the KDL no longer occurs but the desktop never loads... I get a desktop, one icon, and things completely lock.

disabling ACPI has no effect.. odd.

Hardware used to be 100% working only a few revisions ago, this system is an HP nc6230 laptop

comment:3 by jprostko, 9 years ago

I'm pretty sure this is due to the changes in hrev38378. After doing a binary search, I determined KDL issues with Wifi I was having were due to that revision. My issue was a KDL caused by using setwep with a WEP key provided. It would run as expected if used as "setwep [device] [ssid]", but would KDL immediately if used as "setwep [device] [ssid] [wep_key]". Providing a valid or invalid WEP key didn't matter, as anything after the SSID would cause the KDL. I eventually just updated to hrev38595, but undid the changes done in hrev38378. The KDL went away, and things seemed to return to normal.

This happened for me with an Atheros chipset. I took pictures of the KDL, but may not be able to upload them until after Ohio LinuxFest this weekend. I may open a new ticket as well, seeing as kallisti5's symptoms are somewhat different.

comment:4 by andrewbachmann, 9 years ago

Cc: andrewbachmann added
Keywords: kdl setwep wifi wireless added

Additional information from duplicate ticket:

I came to SHDH 40 and my wireless (intel 3945) was working in build hrev37267. I rebuilt and installed Haiku and the wireless failed to connect. I tried to do a "setwep" and I ended up in KDL.

Symptoms were also reproduced by ScottMC on his laptop. (Using build hrev38712) Although his wireless (broadcom 43xx) wasn't working before, at least it didn't KDL when running "setwep".

We can also confirm that setwep was not exhibiting this behavior (it did not KDL) in a build around hrev38300 or so. (ScottMC has the exact build number) I can not confirm whether or not my wireless otherwise works in that build at this time.

Last edited 9 years ago by andrewbachmann (previous) (diff)

comment:5 by luroh, 9 years ago

Cc: luroh added

comment:6 by andrewbachmann, 9 years ago

I can now confirm that hrev38377 does not exhibit KDL when using setwep. Unfortunately, the wireless intel 3945 does not successfully obtain an IP in that build. The system log says "DHCP timeout shift". An IP was obtained and it worked properly in build hrev37267.

comment:7 by korli, 9 years ago

Also confirmed here with GCC2. Without hrev38378, setwep doesn't go to KDL (stacktrace ends with compat_ioctl -> wlan_ioctl -> NULL).

comment:8 by andrewbachmann, 9 years ago

I made another build to test from hrev37793 and I was able to establish a wireless connection.

comment:9 by kallisti5, 9 years ago

Verified I am still seeing the exact same KDL on hrev38734 on my nc6230.

I don't think this is the same issue you guys are seeing with setwep, this is on boot.

comment:10 by andrewbachmann, 9 years ago

kallisti5 can you try hrev38377? If that also exhibits your problem, I will open another ticket for the setwep KDL issue. I have already opened another ticket for the wireless intel 3945 DHCP issue. #6651

comment:11 by kallisti5, 9 years ago

It does indeed look like the issue in my case is caused by hrev38378 as well.

==============================================
Intel 2200 Wifi net_server KDL troubleshooting
==============================================

r38414 GCC4 Hybrid	--	KDL
r38383 GCC4 Hybrid	--	KDL
r38360 GCC4 Hybrid	--	boots ok
r38343 GCC2 Hybrid	--	boots ok

comment:12 by axeld, 9 years ago

Resolution: fixed
Status: newclosed

Fixed in hrev38838.

comment:13 by korli, 9 years ago

Confirmed to fix the crash for me

Note: See TracTickets for help on using tickets.