Opened 9 years ago

Last modified 15 months ago

#6538 in-progress bug

CodyCam can't find video source (for formerly working webcam)

Reported by: Meanwhile Owned by: mmu_man
Priority: normal Milestone: R1
Component: Applications/CodyCam Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

One of the few webcams that worked in Haiku, doesn't do so in hrev38360. It worked in hrev36930. Webcam info: http://reviews.cnet.com/webcams/macally-icecam/4505-6502_7-30787395.html
The error message says: "Cannot find a video source. You need a webcam to use CodyCam."

Change History (5)

comment:1 by mmu_man, 9 years ago

Status: newin-progress

Yes I know the driver is broken currently, also CodyCam insist on having 320x240 or so, and it's possible the current version of the driver doesn't force this resolution anymore.

comment:2 by Meanwhile, 9 years ago

OK, just let me know if you need testers

comment:3 by modeenf, 7 years ago

With What driver?

comment:4 by modeenf, 7 years ago

the only changes in usb_webcam are this.. hrev37670 and hrev37466. None of them looks like they should have any impact on this error.

comment:5 by cocobean, 15 months ago

Reviewed on hrev 52013.

Test Hardware: Logitech QuickCam Pro 5000

Test Hardware resolution: up to 640 x 480 resolution

Yours: Up to 352 x 288 resolution

Codycam default resolution is: 320x240

Codycam's resolution is hard set. Seems a UVC driver issue in mounting certain USB webcams exists.

Last edited 15 months ago by cocobean (previous) (diff)
Note: See TracTickets for help on using tickets.