Opened 9 years ago

Closed 8 years ago

#6544 closed bug (fixed)

Media Preferences Windows's Height Successfully Measured as One Yard High, Refuses to Resize to a Respectable Level

Reported by: NathanP Owned by: yourpalal
Priority: normal Milestone: R1
Component: Preferences/Media Version: R1/Development
Keywords: media preferences window resizing Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I've been noticing an odd issue involving the media preferences window when navigating through it. When switching through the available options and tabs, the height of the window will begin to increase; in some cases by small increments, in other cases, large onces. This may not sound like much of an issue, but you can't resize the window once it's started resizing itself. I've noticed that closing and then reopening the window allows you to reduce the height by roughly one centimeter, and if you spend at least ten minutes doing this non-stop, you will be able to reduce the window to its original size. Alternatively, I've also noticed that if you begin to randomly click around the window's options, it will (eventually) stop resizing on its own and allow you to resize it to whatever height you wish.

The title is also correct in that the window's managed to stretch itself to roughly one yard in height. Don't ask.

This issue has been occuring on Haiku R1, Alpha 2 and Revision 38153. This has also been happening on essentially every revision in between.

Change History (9)

comment:1 Changed 9 years ago by yourpalal

Owner: changed from anevilyak to yourpalal
Status: newassigned

Taking ownership of this as it is probably a layout bug.

comment:2 Changed 9 years ago by stippi

Perhaps a hint: Some BViews report their *current* size in GetPreferredSize(). The default implementation of MinSize() uses GetPreferredSize(). So if you have a view in the hierarchy which is not properly layout friendly, you get this "window can never shrink" behavior.

comment:3 in reply to:  2 Changed 9 years ago by yourpalal

Replying to stippi:

Perhaps a hint: Some BViews report their *current* size in GetPreferredSize(). The default implementation of MinSize() uses GetPreferredSize(). So if you have a view in the hierarchy which is not properly layout friendly, you get this "window can never shrink" behavior.

Yeah, that is what I was thinking too, it might be that when the view is not layout friendly, we ought to use GetPreferredSize() in MaxSize() as well, so that we at least avoid this behaviour (currently it composes the explicit max with B_SIZE_UNLIMITED).

That being said, there also appears to be something funky in the preflet itself, killing media_server produces a large white block in Audio and Video settings. Switching between tabs in either of those settings causes the window to slowly creep in size as well.. :(

comment:4 Changed 9 years ago by stippi

It's certainly not healthy when some views don't report stable Min/MaxSize() without invalidating the layout inbetween. I anticipate the problem to go away when all embedded views use layouting properly. Some of it is generated by the BMediaTheme stuff.

comment:5 Changed 9 years ago by NathanP

I should add that if the media_addon_server crashes and you go to the media preferences window to restart it, the window's height nearly doubles in size instead of by small increments.

comment:6 Changed 9 years ago by stargatefan

I will comfirm this happens.Oddly it does not happen with the soundblaster driver ??? but the opensound driver and the intel driver seem to cuase this issue.

Having this issue with a panasonic cf-29 toughbook

Welcome to the Haiku shell.

~> listdev

device Communication controller (Modem, Generic) [7|3|0]

vendor 8086: Intel Corporation device 24c6: 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller

device Multimedia controller (Multimedia audio controller) [4|1|0]

vendor 8086: Intel Corporation device 24c5: 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller

device Serial bus controller (SMBus) [c|5|0]

vendor 8086: Intel Corporation device 24c3: 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller

device Mass storage controller (IDE interface) [1|1|8a]

vendor 8086: Intel Corporation device 24ca: 82801DBM (ICH4-M) IDE Controller

device Bridge (ISA bridge) [6|1|0]

vendor 8086: Intel Corporation device 24cc: 82801DBM (ICH4-M) LPC Interface Bridge

device Network controller (Ethernet controller) [2|0|0]

vendor 10ec: Realtek Semiconductor Co., Ltd. device 8139: RTL-8139/8139C/8139C+

device Bridge (CardBus bridge) [6|7|0]

vendor 1180: Ricoh Co Ltd device 0476: RL5c476 II

device Bridge (CardBus bridge) [6|7|0]

vendor 1180: Ricoh Co Ltd device 0476: RL5c476 II

device Bridge (PCI bridge, Normal decode) [6|4|0]

vendor 8086: Intel Corporation device 2448: 82801 Mobile PCI Bridge

device Serial bus controller (USB Controller, EHCI) [c|3|20]

vendor 8086: Intel Corporation device 24cd: 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller

device Serial bus controller (USB Controller, UHCI) [c|3|0]

vendor 8086: Intel Corporation device 24c4: 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2

device Serial bus controller (USB Controller, UHCI) [c|3|0]

vendor 8086: Intel Corporation device 24c2: 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1

device Display controller [3|80|0]

vendor 8086: Intel Corporation device 3582: 82852/855GM Integrated Graphics Device

device Display controller (VGA compatible controller, VGA controller) [3|0|0]

vendor 8086: Intel Corporation device 3582: 82852/855GM Integrated Graphics Device

device Bridge (PCI bridge, Normal decode) [6|4|0]

vendor 8086: Intel Corporation device 3581: 82852/82855 GM/GME/PM/GMV Processor to AGP Controller

device Generic system peripheral [8|80|0]

vendor 8086: Intel Corporation device 3585: 82852/82855 GM/GME/PM/GMV Processor to I/O Controller

device Generic system peripheral [8|80|0]

vendor 8086: Intel Corporation device 3584: 82852/82855 GM/GME/PM/GMV Processor to I/O Controller

device Bridge (Host bridge) [6|0|0]

vendor 8086: Intel Corporation device 3580: 82852/82855 GM/GME/PM/GMV Processor to I/O Controller

~>

comment:7 Changed 9 years ago by yourpalal

Status: assignedin-progress

comment:8 Changed 8 years ago by yourpalal

This is mostly fixed now (hrev40127), at least you can resize the window much more easily, the problem seems to be coming from the custom TabView used by the default media theme. Once I can confirm this, I will open a blocking ticket for that issue.

comment:9 Changed 8 years ago by yourpalal

Resolution: fixed
Status: in-progressclosed

Fixed tab issue, which actually came from BTabView.

Note: See TracTickets for help on using tickets.