Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6695 closed bug (invalid)

WebPositive missing library -- easy

Reported by: bbjimmy Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev38891

launching webpositive on a fresh build:

Could not open "WebPositive" (Missing libraries: libstdc++.so).

solution: add a link to libstdc++.so.6.0.10 named libstdc++.so in "/boot/common/lib/gcc4"

Attachments (2)

clip.png (51.2 KB) - added by bbjimmy 9 years ago.
A screenshot of the error in hrev38948
clip1.png (52.0 KB) - added by bbjimmy 9 years ago.
the files listing for /boot/system/lib/gcc4 on a new image

Download all attachments as: .zip

Change History (11)

comment:1 Changed 9 years ago by luroh

hrev38901 may have helped, could you give it a try?

comment:2 Changed 9 years ago by bbjimmy

As soon as I can compile again, I will let you know.

C++ /DATA/haiku/generated.gcc4/objects/haiku/x86/release/add-ons/translators/bmp/BMPView.o /DATA/haiku/src/add-ons/translators/bmp/BMPView.cpp:46:3: error: could not determine date and time: Function not implemented

comment:3 Changed 9 years ago by mmadia

Resolution: invalid
Status: newclosed

WebPositive works properly on hrev38900-gcc2 hybrid.

comment:4 in reply to:  3 Changed 9 years ago by bbjimmy

Replying to mmadia:

WebPositive works properly on hrev38900-gcc2 hybrid.

WebPositive works for me as well, once I add a link to libstdc++.so.6.0.10 named /boot/common/lib/gcc4/libstdc++.so

Changed 9 years ago by bbjimmy

Attachment: clip.png added

A screenshot of the error in hrev38948

comment:5 Changed 9 years ago by bbjimmy

Resolution: invalid
Status: closedreopened

comment:6 Changed 9 years ago by mmadia

Resolution: invalid
Status: reopenedclosed

libstdc++.so is part of Haiku. It lives in /boot/system/lib/gcc4. If you do not have that folder (or these following files), then your Haiku installation is broken.

/boot/system/lib/gcc4> ls -1
libGL.so
libGLU.so
libbe.so
libbnetapi.so
libbsd.so
libdebug.so
libdevice.so
libfluidsynth.so
libfreetype.so
libgame.so
libglut.so
libgnu.so
libicudata.so.44
libicui18n.so.44
libicuio.so.44
libicule.so.44
libiculx.so.44
libicutu.so.44
libicuuc.so.44
libilmimf.so
libjpeg.so
libjpeg.so.8.0
liblocale.so
liblpsolve55.so
libmail.so
libmedia.so
libmidi.so
libmidi2.so
libnetwork.so
libpng.so
libpng.so.1.4
libroot-addon-icu.so
libroot.so
libroot_debug.so
libscreensaver.so
libstdc++.so
libsupc++.so
libtextencoding.so
libtiff.so
libtiff.so.3.8
libtracker.so
libtranslation.so
libz.so
libz.so.1
/boot/system/lib/gcc4> 

Changed 9 years ago by bbjimmy

Attachment: clip1.png added

the files listing for /boot/system/lib/gcc4 on a new image

comment:7 Changed 9 years ago by bbjimmy

indeed it is broken, that is what the ticket is all about.

comment:8 Changed 9 years ago by anevilyak

I'm not seeing the behavior you describe on hrev38948 here. Hence the assumption that your installation is broken, since other people do not appear to be seeing the reported behavior.

comment:9 Changed 9 years ago by Disreali

duplicate of ticket:6327

Note: See TracTickets for help on using tickets.