Opened 9 years ago

Closed 9 months ago

#6702 closed bug (fixed)

Mail ignores "From" account

Reported by: humdinger Owned by: bga
Priority: normal Milestone: R1
Component: Applications/Mail Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev38894.

I have set up a first mail account at GMail and a second one at GMX.
Even when specifying the GMX account in Mail, the mail gets send from the GMail account. Checking the mail's header in a text editor and looking into the MAIL:from attribute, I see the GMail account.
Looks like Mail ignores the "From" account pop-up menu when writing header/attributes of a mail and sets the first/default account. I think I remember it working a month or so ago...

[BTW: As reported in #4789, saving a mail as draft doesn't write a MAIL:from attribute at all...]

Change History (4)

comment:1 by waddlesplash, 11 months ago

Still an issue?

comment:2 by taos, 10 months ago

I have set up two accounts in Mail (it's essentially the same account with both the actual e-mail address and an alias address as sender name). It seems that only mails from the second account with the alias address are actually sent. Mails from both accounts end up in the outbox and there's no error message while sending. However, only the mails from the alias address are received. As far as I can tell, apart from the mail address, all settings are the same.

comment:3 by taos, 10 months ago

Please, ignore the latest comment. Mails from both accounts eventually reach the recipients - although in case of the first account with a delay of ~9 hours....

comment:4 by humdinger, 9 months ago

Resolution: fixed
Status: newclosed

Can't reproduce anymore either. Fixed.

Note: See TracTickets for help on using tickets.