Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6703 closed enhancement (fixed)

Highlighted RGB values at tab-through after changing one

Reported by: Meanwhile Owned by: korli
Priority: normal Milestone: R1
Component: Preferences/Backgrounds Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

In backgrounds preferences, when using the Tab key to navigate, the individual RGB values aren't selected, though their boxes are. It would save a click if they were highlighted straight away. The attachment shows the desired situation on the right, current situation on the left.

Attachments (1)

RGBexamples.png (4.6 KB) - added by Meanwhile 9 years ago.

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by Meanwhile

Attachment: RGBexamples.png added

comment:1 Changed 9 years ago by Meanwhile

Ahem, I can't reproduce it?!

comment:2 Changed 9 years ago by Meanwhile

Correction

Last edited 9 years ago by Meanwhile (previous) (diff)

comment:3 Changed 9 years ago by anevilyak

Resolution: invalid
Status: newclosed

Please reopen if you manage to find a reproducible set of steps for this.

comment:4 Changed 9 years ago by Meanwhile

Resolution: invalid
Status: closedreopened
Summary: Highlighted RGB values at tab-throughHighlighted RGB values at tab-through after changing one

comment:5 Changed 9 years ago by Meanwhile

(Messed up again...)

Adding to original description: It happens only after a value has been changed, and then only concerns the next value.

Here are the steps:

1) Open 'Backgrounds' preference window
2) Click inside value field for Red; the value is highlighted.
3) Change the value, press Tab key
4) The next value (Green) isn't highlighted, while its box is.
5) Press Tab key again and the wanted behaviour is restored: 'Blue' value is highlighted, together with its box.

It's still an enhancement, but also a bit more something like a bug (IMHO).

comment:6 Changed 9 years ago by korli

Resolution: fixed
Status: reopenedclosed

Fixed in hrev38900.

comment:7 Changed 9 years ago by Meanwhile

Thanks for the instant fix

Note: See TracTickets for help on using tickets.