Opened 9 years ago

Closed 3 years ago

#6709 closed bug (invalid)

gnash crashs/hogs media_server_add_on and one thread in particular "audio mixer control thread"

Reported by: stargatefan Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/media_addon_server Version: R1/alpha2
Keywords: gnash Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

there is some issue with gnash in bezilla that seems to be cuasing most of the grief with gnash. It seems to totally hog up the media_server_add_on "audio mixer control thread" and it also create a new mixer entry everytime you reload a page, these mixer entrys also never leave the mix control panel under prefrences.

I have no idea exactly where the problem is but I got a though its a issue with firefox becuase it seems to act alot like the memory leakage problem under windows. Just with audio instead. either that or the mixer is doing something odd.

it would seem that the Media_Add_On_server "audio Mixer control" Thread is not playing nice here.

give it a shot. Gnash works fine for a few seconds and then flakes out as soon as the thread useage hits 100%. so its something between the server and gnash. video plays fine though.

Change History (4)

comment:1 by MichaelPeppers, 9 years ago

BeAE also creates a new mixer entry every time you use it, and permanently as well, plus it doesn't seem to work anymore and crashes when you quit it.

My bet, as obvious as it may sound, is that some code has changed in the way the Media Add-on server handles audio threads and the software must be updated accordingly, since MediaPlayer, as an example of continuously updated software that uses the Media Add-on sever, has no such problems.

Last edited 9 years ago by MichaelPeppers (previous) (diff)

comment:2 by stargatefan, 9 years ago

Well it has never worked for me at all. thats going back to at least r1a2.

comment:3 by Barrett, 4 years ago

This issue should have been resolved in the recent BMediaEventLooper changes, i've not unfortunately any way to verify this for 100%, but if someone is listening please test and report :-)

comment:4 by Barrett, 3 years ago

Resolution: invalid
Status: newclosed

No way to solve it:

  • no stack trace
  • impossible to replicate
  • obsolete component.
Note: See TracTickets for help on using tickets.