Opened 9 years ago

Closed 9 years ago

#6715 closed enhancement (invalid)

Network Printing Transport Layer

Reported by: stargatefan Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/net_server Version: R1/alpha2
Keywords: Printing network printer print Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

check ticket and source, I didn't see anything on this issue. Will be a much needed enhancement in the age of wireless/networked printer.

Change History (9)

comment:1 by ithamar, 9 years ago

Most of these printers support the IPP protocol. If it does not broadcast its status (like printers used with CUPS do), you should be able to set it up manually by specifying the URL in the IPP setup dialog from the Printers preference.

comment:2 by stargatefan, 9 years ago

needs to be very simple. Have the utility search for and identify printers behind or attached to the router and have it offer itself as a selectable printer. Thats a bit complicated for the end user. some people have a hard time operating a coffe maker much less setting up a network printer. I however would be willing to try with a few different network printers when the work on the Gueten print bounty comes along a bit further.

comment:3 by stargatefan, 9 years ago

I tested with the guetenprint driver on the last 3 nightlys. Either gueten print or the network transport layer does not work.

How can I trace this bug to find out the cuase ? I traced it on my server to see if haiku sent a message to the router or printer. It did not.

in reply to:  3 comment:4 by ithamar, 9 years ago

Replying to stargatefan:

How can I trace this bug to find out the cuase ? I traced it on my server to see if haiku sent a message to the router or printer. It did not.

The easiest way is to start the print_server from a Terminal, and log the output of that. You can quit the print_server using Process Controller, and then from a Terminal type "/boot/system/servers/print_server" to start it again.

The output spilled into the Terminal would probably be very helpful for debugging where the problem is exactly occurring.

Also, stating the printer used, and the printer type selected would be useful too, ofcourse :)

comment:5 by stargatefan, 9 years ago

will be testing tonight, there is a bug in gueten print with margins that stalls guetenprint. will report back with all findings and traces.

would it be possiable to write a utility to find the printer and set the IP adress automatically ? I look at new users who are not terriably network or computer savy and I imagine they nmight get fustrated. For instance my printer ip is 192.168.2.2 and it has a page if you goto the adress that displays the printer info. I wonder if we could take advantage of the html code on the printer dialog page to identify printers and have the setup utility select the proper IP adress after scanning the IP blocks say from 192.168.0.0-.254.254 that shoud make it stone simple for the average home user.

in reply to:  5 comment:6 by ithamar, 9 years ago

Replying to stargatefan:

would it be possiable to write a utility to find the printer and set the IP adress automatically ? I look at new users who are not terriably network or computer savy and I imagine they nmight get fustrated. For instance my printer ip is 192.168.2.2 and it has a page if you goto the adress that displays the printer info. I wonder if we could take advantage of the html code on the printer dialog page to identify printers and have the setup utility select the proper IP adress after scanning the IP blocks say from 192.168.0.0-.254.254 that shoud make it stone simple for the average home user.

There is something like that for any printers which are shared through CUPS, as I had documentation on how CUPS broadcasts the available printers. Now, for real networked printers I don't know if there's anything. I might have a networked printer available soon, so I could verify if it does broadcast anything.

If anybody has any hints on identifying these printers (maybe possible through zeroconf or some such), I would love to hear how, and would volunteer to implement it in the transport addon, besides the CUPS support that is implemented currently.

comment:7 by stargatefan, 9 years ago

Let me snoop around I think I might know someone who might hold the key to this. I know when I install the epson software on my winxp partition that the epson software searchs for the printer via some method I am sure I could watch it from the router dialog. Maybe we could log the way it searchs. My other thought is that the printer should be able to be pinged. So we might be able to send out pings to all adress's and have those return pings self identify and then have the user select the one that returns the proper name. I also think most network printers have a mac ID block that each manufacturer tends to use. So it might be possiable to look for specific mac ID headers. IE epson might use mac-0005-0345-789 and that all epson devices use 0005.

I'll see what I can find for ya.

comment:8 by stargatefan, 9 years ago

Ok I tried some new information on haikuware which states that margin must be 0.4inchs. I set the margins to 0.4 inchs and set the IP adress. Haiku printed the image.

So this ticket can be closed but a new one needs to be made regarding image distortion.

I am going to start 3 new tickets to adress the issue seperately.

  1. printer ID over the network and self location
  2. the margin issue needs repair
  3. image distortion.

Last edited 9 years ago by stargatefan (previous) (diff)

comment:9 by phoudoin, 9 years ago

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.