Opened 9 years ago

Closed 3 years ago

#6716 closed bug (fixed)

nVidia GeForce 7025: no screen resolutions higher than 800x600

Reported by: MichaelPeppers Owned by: rudolfc
Priority: normal Milestone: R1
Component: Drivers/Graphics/nVidia Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #7655
Has a Patch: no Platform: All

Description

hrev38969 here, I'm using an nVidia GeForce 7025 nForce 630a with an old CRT screen. With the current nvidia driver I'm unable to set the screen to a resolution higher than 800x600.

In VESA mode I succeeded in setting the resolution to 1280x1024, also the official drivers in other operating systems have it working at 1152x864 with no problem at all.

Could be related to bug #2066 as far as I can tell.

Attachments (3)

syslog.zip (57.0 KB) - added by MichaelPeppers 9 years ago.
Syslog
syslog (96.5 KB) - added by MichaelPeppers 9 years ago.
Syslog (a cleaner one)
nvidia.10de_03d6_000d00.0.log (55.3 KB) - added by MichaelPeppers 9 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 9 years ago by luroh

Please attach a syslog.

comment:2 Changed 9 years ago by diver

Detection of GeForce 7025 was added in hrev38614.

Changed 9 years ago by MichaelPeppers

Attachment: syslog.zip added

Syslog

comment:3 in reply to:  1 Changed 9 years ago by MichaelPeppers

Replying to luroh:

Please attach a syslog.

Done, sir. =)

Changed 9 years ago by MichaelPeppers

Attachment: syslog added

Syslog (a cleaner one)

comment:4 Changed 9 years ago by MichaelPeppers

Sh*t, I messed up the attachment system, sorry guys. The 3 syslogs are identical.

comment:5 Changed 9 years ago by anevilyak

Extras cleaned up.

comment:6 Changed 9 years ago by luroh

Great, thanks. If possible, please also create and attach an nvidia driver log file, there are instructions on how to create one in the readme file over here: http://dev.haiku-os.org/browser/haiku/trunk/src/add-ons/kernel/drivers/graphics/nvidia

Changed 9 years ago by MichaelPeppers

comment:7 in reply to:  6 Changed 9 years ago by MichaelPeppers

Replying to luroh:

Great, thanks. If possible, please also create and attach an nvidia driver log file, there are instructions on how to create one in the readme file over here: http://dev.haiku-os.org/browser/haiku/trunk/src/add-ons/kernel/drivers/graphics/nvidia

Attached. Just took a look at it, the problem is signaled from line 698 onwards.

Last edited 9 years ago by MichaelPeppers (previous) (diff)

comment:8 Changed 9 years ago by rudolfc

Hi,

The driver detects EDID/DDC successfully. It interprets the extra modelines reported only since on 99% (all but two I've seen sofar) screens here the max resolution it can display is reported. On this screen however this is not the case: it reports 800x600 here only.

This is the reason higher res modes are not offered in the screenprefs panel.

I don't think the nvidia.settings file supports a setting for disabling use of EDID yet.

There are three solutions to the problem:

  • use another screen: your card is working properly :-)
  • extend the driver to support to not use edid
  • modify / extend the driver to also interpret the fixed modelines to find the highest possible mode. Probably Axel has something for that in his driver(s)?

Personally I currently don't have time to look further at this, sorry..

Rudolf.

comment:9 in reply to:  8 Changed 9 years ago by axeld

Replying to rudolfc:

Probably Axel has something for that in his driver(s)?

I would doubt that :-) But it would certainly be a good idea to have something like this. I would think the best way to implement this would be using the driver settings, as its a serious thing to override the monitor's reported capabilities, and will probably only be used rarely.

comment:10 in reply to:  8 Changed 9 years ago by MichaelPeppers

Replying to rudolfc:

Hi,

The driver detects EDID/DDC successfully. It interprets the extra modelines reported only since on 99% (all but two I've seen sofar) screens here the max resolution it can display is reported. On this screen however this is not the case: it reports 800x600 here only.

This is the reason higher res modes are not offered in the screenprefs panel.

I don't think the nvidia.settings file supports a setting for disabling use of EDID yet.

There are three solutions to the problem:

  • use another screen: your card is working properly :-)
  • extend the driver to support to not use edid
  • modify / extend the driver to also interpret the fixed modelines to find the highest possible mode. Probably Axel has something for that in his driver(s)?

Personally I currently don't have time to look further at this, sorry..

Rudolf.

No worries, thanks for the explaination. I'll stick with VESA for now, since it works fairly well for my needs. (I'll have to buy another screen sooner or later, though ;) )

Last edited 9 years ago by MichaelPeppers (previous) (diff)

comment:11 Changed 3 years ago by pulkomandy

Blocking: 7655 added

comment:12 Changed 3 years ago by rudolfc

Hi there,

hrev49984 added a new nv.settings settings file setting called 'check_edid'. Set this setting to false to block the driver from preventing higher resolution modes from appearing in the ScreenPrefs app. This overcomes the problem of only being able to use low-res modes.

Be carefull not to use too high resolution modes though, as your monitor will not like that...

Closing ticket.

Bye!

Rudolf.

comment:13 Changed 3 years ago by rudolfc

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.