Opened 9 years ago

Closed 4 years ago

#6834 closed enhancement (fixed)

add spinner widget [PATCH]

Reported by: Disreali Owned by: jscipione
Priority: normal Milestone: Unscheduled
Component: Kits/Interface Kit Version: R1/Development
Keywords: spinner Cc:
Blocked By: Blocking: #8056, #8057
Has a Patch: yes Platform: All

Description

A spinner widget would be very useful for Haiku.

Libwalter includes a spinner http://dev.osdrawer.net/projects/libwalter

Attachments (2)

add_spinner.diff (23.7 KB ) - added by Disreali 8 years ago.
add_spinner_02.diff (24.0 KB ) - added by Disreali 8 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 by Disreali, 8 years ago

Component: - GeneralKits/Interface Kit
Keywords: spinner added
Owner: changed from nobody to axeld
Summary: add spinner widgetadd spinner widget [PATCH]

Attaching a patch that literally copies the Spinner.cpp and Spinner.h files from LibWalter to the, hopefully, appropriate locations in the Haiku src tree.

*Please review.* I don't know if there are any jam file adjustments that need to be done.

It would be really useful to replace the sliders in the VirtualMemory pref and DriveSetup with spinners.

by Disreali, 8 years ago

Attachment: add_spinner.diff added

comment:2 by Disreali, 8 years ago

Has a Patch: set

comment:3 by Disreali, 8 years ago

I deduced the jamfile adjustment needed, and created an updated patch. I did a fresh build (jam -qa @alpha-raw) and there was no error given about adding the spinner files.

*PLEASE REVIEW* I can only assume that the code works as intended.

by Disreali, 8 years ago

Attachment: add_spinner_02.diff added

comment:4 by Disreali, 8 years ago

Here is another patch that could benefit from dev review at the upcoming BG.

I do not know if the code actually does what is supposed to, as I mention before, I just copied it from libWalter.

comment:5 by leavengood, 7 years ago

I agree this could be useful but if anything this should start in the shared kit or otherwise somewhere private.

Generally we need to be careful about adding new classes like this to the Interface Kit, since it may need some API tweaking (and in this case definitely some object padding) before it can be deemed worthy of being public and therefore supported by Haiku for who knows how long.

If we can find a good use for this class in a few places in Haiku, I could see it getting added faster (though like I said, probably not to the Interface Kit first.)

Also please mark old patches obsolete when you update them.

in reply to:  5 ; comment:6 by Disreali, 7 years ago

Blocking: 8056, 8057 added

Replying to leavengood:

If we can find a good use for this class in a few places in Haiku, I could see it getting added faster (though like I said, probably not to the Interface Kit first.)

Tickets #8056 and #8057 were created for that reason.

Also please mark old patches obsolete when you update them.

Sorry, I've not been successful in obsoleting anything on trac.

in reply to:  6 ; comment:7 by leavengood, 7 years ago

Replying to Disreali:

Tickets #8056 and #8057 were created for that reason.

OK great, those are indeed good cases for using the spinner. I'll add this ticket and those to my personal TODO list for sometime in the next few months. I won't take ownership since I may not get to it for a while, and maybe someone else can do it in the meantime.

Sorry, I've not been successful in obsoleting anything on trac.

OK, I guess only users with certain permissions (maybe just admins, I'm not sure) can mark obsolete patches. Though it is weird you cannot mark something you uploaded as obsolete.

in reply to:  7 ; comment:8 by nielx, 7 years ago

Replying to leavengood:

Replying to Disreali:

Tickets #8056 and #8057 were created for that reason.

OK great, those are indeed good cases for using the spinner. I'll add this ticket and those to my personal TODO list for sometime in the next few months. I won't take ownership since I may not get to it for a while, and maybe someone else can do it in the meantime.

Sorry, I've not been successful in obsoleting anything on trac.

OK, I guess only users with certain permissions (maybe just admins, I'm not sure) can mark obsolete patches. Though it is weird you cannot mark something you uploaded as obsolete.

Please file a bug for that! I will have to look at that because it is not right.

in reply to:  8 comment:9 by leavengood, 7 years ago

Replying to nielx:

Please file a bug for that! I will have to look at that because it is not right.

Done: #8869.

comment:10 by pulkomandy, 5 years ago

Milestone: R1Unscheduled

comment:12 by pulkomandy, 4 years ago

Owner: changed from axeld to jscipione
Status: newassigned

I think we have one now?

comment:13 by jscipione, 4 years ago

Resolution: fixed
Status: assignedclosed

Yes we can close this one now.

Spinner widget added in hrev49568

Note: See TracTickets for help on using tickets.