Opened 7 years ago

Closed 7 years ago

#8869 closed bug (invalid)

Users cannot mark their own attachments as obsolete

Reported by: leavengood Owned by: haiku-web
Priority: normal Milestone: R1
Component: Website/Trac Version: R1/Development
Keywords: attachments Cc: Disreali
Blocked By: Blocking:
Has a Patch: yes Platform: All

Description

Well at least Disreali claimed he was unable to mark one of his patches as obsolete on #6834.

I was able to do it though, but I am an admin user.

Attachments (4)

makehaikufloppy (2.9 KB) - added by testnielx 7 years ago.
test
add_spinner.2.diff (23.7 KB) - added by Disreali 7 years ago.
test 2
add_spinner.diff (23.7 KB) - added by Disreali 7 years ago.
test 3
add_spinner.3.diff (23.7 KB) - added by Disreali 7 years ago.

Download all attachments as: .zip

Change History (11)

Changed 7 years ago by testnielx

Attachment: makehaikufloppy added

test

comment:1 Changed 7 years ago by testnielx

Has a Patch: set

comment:2 Changed 7 years ago by testnielx

Has a Patch: unset

comment:3 Changed 7 years ago by testnielx

Has a Patch: set

comment:4 Changed 7 years ago by nielx

Cc: Disreali added

I actually cannot reproduce this. Disreali: could you try it here again and make a screenshot of how it looks when it does not work?

Changed 7 years ago by Disreali

Attachment: add_spinner.2.diff added

test 2

Changed 7 years ago by Disreali

Attachment: add_spinner.diff added

test 3

comment:5 Changed 7 years ago by Disreali

I think the issue is that there are no instructions on how to make attachment obsolete.

The process is some what obtuse, and not easy to figure out.

I have to add the same file a second time, select the "Replace existing attachment of the same name" checkbox, and select the obsolete checkbox.

A regular user does not seem to be able to simply set the status of an existing attachment.

Changed 7 years ago by Disreali

Attachment: add_spinner.3.diff added

comment:6 Changed 7 years ago by Disreali

I attached the 'add_spinner.3.diff' and selected the patch checkbox, but I can't tell if it is marked as a patch.

comment:7 Changed 7 years ago by nielx

Resolution: invalid
Status: newclosed

The patch flags are at the bottom of the attachment. The next time I will touch the attachmentflags module I will see if I can move it up. For now this ticket is invalid.

Note: See TracTickets for help on using tickets.