Opened 9 years ago

Closed 6 years ago

Last modified 7 weeks ago

#6870 closed bug (fixed)

Tabbing to a checkbox not working

Reported by: Coldfirex Owned by: pulkomandy
Priority: high Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Howdy, I installed Haiku R39551 GCC2Hybrid in VirtualBox, and installed WebPostiive (hrev545). I noticed that I can tab between different boxes when filling in a form (for instance the username and password fields on a signon page), but that I cannot tab to a checkbox for it to save my password. I confirmed this on Gmail and Facebook's login pages.

Change History (7)

comment:1 by luroh, 9 years ago

Component: - GeneralApplications/WebPositive
Owner: changed from nobody to stippi
Status: newassigned
Version: R1/alpha2R1/Development

comment:2 by aldeck, 7 years ago

Priority: normalhigh

comment:3 by pulkomandy, 6 years ago

Owner: changed from stippi to pulkomandy

From the webkit-dev ML:

Safari is unique among desktop browsers in that "full keyboard access" (FKA) is off by default, and the Tab key moves focus only to textfields and select elements. You can modify this behavior using a system-wide setting (System Prefs > Keyboard > Shortcuts > All Controls) and/or a Safari-specific setting (Safari > Prefs > Advanced > Press Tab to…). If you change both settings, you'll have a keyboard focus behavior that is similar to that of other desktop browsers, such that every "focusable" control appears in the sequential Tab order.

Changing these settings default value in our port may help.

comment:4 by pulkomandy, 6 years ago

Resolution: fixed
Status: assignedclosed

comment:5 by WildKeccak, 7 weeks ago

Does exactly what it says in the summary now. Dogfood. hrev53556 x86-64 Ryzen 5 3400G

Last edited 7 weeks ago by WildKeccak (previous) (diff)

comment:6 by humdinger, 7 weeks ago

Are you testing the new "preview Web+" ?

Because for me it is working with the stock hrev53538 (32bit) Haiku, but not with the preview. I tested with this Trac site login. Tabbing through the widgets works, i.e. I see the checkbox outlined and after another tab the Login button outlined, but I cannot tick the checkbox or activate the button with the space key or return.

comment:7 by WildKeccak, 7 weeks ago

I tested it on Yahoo's mail login page. It works today. hrev53559 x86-64 Ryzen 5 3400G

Last edited 7 weeks ago by WildKeccak (previous) (diff)
Note: See TracTickets for help on using tickets.