Opened 8 years ago

Closed 7 years ago

#6871 closed bug (fixed)

Crash in Webpositive when accessing a Sharepoint site

Reported by: Coldfirex Owned by: leavengood
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #7438
Has a Patch: no Platform: x86

Description (last modified by humdinger)

Howdy, I installed Haiku R39551 GCC2Hybrid in VirtualBox, and installed WebPostiive (hrev545). I was testing access to our company's Sharepoint (WSS3) site and got a crash in WebPositive. I experienced the crash after entering my credentials or if I cancel out of the credential popup. Below is the dump:

GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i586-pc-haiku"...(no debugging symbols found)

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Thread 228 caused an exception: Segment violation
Reading symbols from /boot/system/runtime_loader...done.
Loaded symbols for /boot/system/runtime_loader
Reading symbols from /boot/apps/WebPositive/lib/libjavascriptcore.so...done.
Loaded symbols for /boot/apps/WebPositive/lib/libjavascriptcore.so
Reading symbols from /boot/apps/WebPositive/lib/libwebcore.so...done.
Loaded symbols for /boot/apps/WebPositive/lib/libwebcore.so
Reading symbols from /boot/apps/WebPositive/lib/libwebkit.so...done.
Loaded symbols for /boot/apps/WebPositive/lib/libwebkit.so
Reading symbols from /boot/common/lib/libcurl.so.4.2.0...done.
Loaded symbols for /boot/common/lib/libcurl.so.4.2.0
Reading symbols from /boot/system/lib/gcc4/libicuuc.so.44...done.
Loaded symbols for /boot/system/lib/gcc4/libicuuc.so.44
Reading symbols from /boot/system/lib/gcc4/libicudata.so.44...
warning: Lowest section in /boot/system/lib/gcc4/libicudata.so.44 is .hash at 00000094
done.
Loaded symbols for /boot/system/lib/gcc4/libicudata.so.44
Reading symbols from /boot/system/lib/gcc4/libpng.so.1.4...done.
Loaded symbols for /boot/system/lib/gcc4/libpng.so.1.4
Reading symbols from /boot/common/lib/libsqlite3.so.0.8.6...done.
Loaded symbols for /boot/common/lib/libsqlite3.so.0.8.6
Reading symbols from /boot/common/lib/libxml2.so.2.7.7...done.
Loaded symbols for /boot/common/lib/libxml2.so.2.7.7
Reading symbols from /boot/system/lib/gcc4/libz.so.1...done.
Loaded symbols for /boot/system/lib/gcc4/libz.so.1
Reading symbols from /boot/system/lib/gcc4/libbe.so...done.
Loaded symbols for /boot/system/lib/gcc4/libbe.so
Reading symbols from /boot/system/lib/gcc4/libbsd.so...done.
Loaded symbols for /boot/system/lib/gcc4/libbsd.so
Reading symbols from /boot/system/lib/gcc4/liblocale.so...done.
Loaded symbols for /boot/system/lib/gcc4/liblocale.so
Reading symbols from /boot/system/lib/gcc4/libnetwork.so...done.
Loaded symbols for /boot/system/lib/gcc4/libnetwork.so
Reading symbols from /boot/system/lib/gcc4/libstdc++.so...done.
Loaded symbols for /boot/system/lib/gcc4/libstdc++.so
Reading symbols from /boot/system/lib/gcc4/libtracker.so...done.
Loaded symbols for /boot/system/lib/gcc4/libtracker.so
Reading symbols from /boot/system/lib/gcc4/libtranslation.so...done.
Loaded symbols for /boot/system/lib/gcc4/libtranslation.so
Reading symbols from /boot/system/lib/gcc4/libroot.so...done.
Loaded symbols for /boot/system/lib/gcc4/libroot.so
Reading symbols from /boot/system/lib/gcc4/libicui18n.so.44...done.
Loaded symbols for /boot/system/lib/gcc4/libicui18n.so.44
Reading symbols from /boot/system/lib/gcc4/libjpeg.so.8.0...done.
Loaded symbols for /boot/system/lib/gcc4/libjpeg.so.8.0
Reading symbols from /boot/system/lib/gcc4/libtextencoding.so...done.
Loaded symbols for /boot/system/lib/gcc4/libtextencoding.so
Reading symbols from /boot/common/lib/libssl.so.1.0.0...done.
Loaded symbols for /boot/common/lib/libssl.so.1.0.0
Reading symbols from /boot/common/lib/libcrypto.so.1.0.0...done.
Loaded symbols for /boot/common/lib/libcrypto.so.1.0.0
Reading symbols from /boot/common/lib/libiconv.so.2.5.0...done.
Loaded symbols for /boot/common/lib/libiconv.so.2.5.0
Reading symbols from /boot/system/lib/gcc4/libicuio.so.44...done.
Loaded symbols for /boot/system/lib/gcc4/libicuio.so.44
Reading symbols from /boot/system/lib/gcc4/libicule.so.44...done.
Loaded symbols for /boot/system/lib/gcc4/libicule.so.44
Reading symbols from /boot/system/lib/gcc4/libiculx.so.44...done.
Loaded symbols for /boot/system/lib/gcc4/libiculx.so.44
Reading symbols from /boot/system/lib/gcc4/libicutu.so.44...done.
Loaded symbols for /boot/system/lib/gcc4/libicutu.so.44
Reading symbols from /boot/system/lib/gcc4/libsupc++.so...done.
Loaded symbols for /boot/system/lib/gcc4/libsupc++.so
Reading symbols from /boot/system/lib/gcc4/libroot-addon-icu.so...done.
Loaded symbols for /boot/system/lib/gcc4/libroot-addon-icu.so
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/apps/WebPositive/WebPositive (228) thread WebPositive (228)]
0x00a2e898 in WebCore::ResourceHandle::didReceiveAuthenticationChallenge ()
   from /boot/apps/WebPositive/lib/libwebcore.so
(gdb) 

I tried a couple public test WSS3 sites, but could not reproduce this issue (http://www.xsolive.com for example). Our WSS3 site works correctly under all other browsers we have tried (IE, FF, Chrome, etc).

Attachments (1)

webpositive crash (5.6 KB) - added by Coldfirex 8 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 8 years ago by humdinger

You should enter "bt" for backtrace in the debugger window for more important info.

comment:2 Changed 8 years ago by humdinger

Description: modified (diff)

Changed 8 years ago by Coldfirex

Attachment: webpositive crash added

comment:3 Changed 8 years ago by Coldfirex

Thanks humdinger. I have uploaded a debug log with the bt command added.

comment:4 Changed 8 years ago by leavengood

Owner: changed from stippi to leavengood
Status: newassigned

Taking ownership.

comment:5 Changed 8 years ago by diver

Blocking: 7438 added

comment:6 Changed 7 years ago by mmadia

Hi. Our WebKit port (and thus WebPositive) was updated in July. Could you retest this in a new nightly image and report back? http://www.haiku-files.org/haiku/development Thanks!

comment:7 Changed 7 years ago by Coldfirex

Just tested with haiku-nightly-hrev44426-x86gcc2hybrid and I can now login and it displays the intial home page. However at this point WebPositive hangs (the wepage itself, not the app), so I am unable to click any links. Additionally I have to kill webpositive to close out of it completely. Enter under a different report?

comment:8 Changed 7 years ago by mmadia

Resolution: fixed
Status: assignedclosed

As the crash no longer happens, we'll close this as fixed. That new behavior sounds like #8806. Could you add a comment on that ticket and either provide a URL or some more information about the website? Thanks!

Note: See TracTickets for help on using tickets.