Opened 9 years ago

Closed 4 years ago

#6874 closed bug (fixed)

[media_addon_server] running Identify from Tracker in /system/add-ons/media folder could crash media_server/media_addon_server/mixer.media_addon

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/media_addon_server Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev39556 gcc4hybrid.

Running Identify from Tracker in (or mimeset -f ) /system/add-ons/media folder could crash media_server/media_addon_server/mixer.media_addon

Thread 176 caused an exception: Segment violation
[...]
[Switching to team /boot/system/servers/media_addon_server (136) thread _BMediaRoster_ (176)]
0x0072b240 in AudioMixer::~AudioMixer ()
   from /boot/system/add-ons/media/mixer.media_addon
(gdb) bt
#0  0x0072b240 in AudioMixer::~AudioMixer ()
   from /boot/system/add-ons/media/mixer.media_addon
#1  0x004a956c in BMediaNode::DeleteHook () from /boot/system/lib/libmedia.so
#2  0x004a4a36 in BMediaEventLooper::DeleteHook ()
   from /boot/system/lib/libmedia.so
#3  0x004adf31 in BMediaRoster::MessageReceived ()
   from /boot/system/lib/libmedia.so
#4  0x002c34d8 in BLooper::DispatchMessage () from /boot/system/lib/libbe.so
#5  0x002c5014 in BLooper::task_looper () from /boot/system/lib/libbe.so
#6  0x002c4d3a in BLooper::_task0_ () from /boot/system/lib/libbe.so
#7  0x0062ba54 in thread_entry () from /boot/system/lib/libroot.so
#8  0x7003ffec in ?? ()
(gdb)

Even if crash dialog won't show up, controls for HDA driver and mixer.media_addon disappears in Media preflet after identifying.



Restart media services gets them back.

Attachments (2)

media.png (9.4 KB) - added by diver 9 years ago.
kdl.png (59.1 KB) - added by diver 9 years ago.

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by diver

Attachment: media.png added

Changed 9 years ago by diver

Attachment: kdl.png added

comment:1 Changed 9 years ago by diver

Haiku could even KDL if you identify /system/add-ons several times in a raw. Could be completely unrelated, though.

comment:2 in reply to:  1 Changed 9 years ago by bonefish

Component: Servers/registrarServers/media_addon_server
Owner: changed from bonefish to axeld

Replying to diver:

Haiku could even KDL if you identify /system/add-ons several times in a raw. Could be completely unrelated, though.

It is unrelated. Cf. #5474.

Changing component to media_addon_server. Could as well be audio mixer or media kit/server related. At any rate it doesn't look registrar related. The only thing registrar does is touching the files. I guess something goes wrong with loading/unloading the media add-ons.

comment:3 Changed 9 years ago by diver

Summary: [registrar] running Identify from Tracker in /system/add-ons/media folder could crash media_server/media_addon_server/mixer.media_addon[media_addon_server] running Identify from Tracker in /system/add-ons/media folder could crash media_server/media_addon_server/mixer.media_addon

Is it expected that mimeset reloads media add-ons, as I see ffmpeg and raw_decoder registration in Terminal output?

comment:4 in reply to:  3 Changed 9 years ago by bonefish

Replying to diver:

Is it expected that mimeset reloads media add-ons, as I see ffmpeg and raw_decoder registration in Terminal output?

mimeset touches the files, which sends out notifications that the files have changed, which in turn causes the media_addon_server to reload them. While it wouldn't be necessary in this case, there's no way to avoid it either.

comment:5 Changed 4 years ago by Barrett

Resolution: fixed
Status: newclosed

Can't reproduce it on recent revs.

Note: See TracTickets for help on using tickets.