Opened 9 years ago

Closed 4 years ago

Last modified 9 months ago

#6889 closed bug (fixed)

[Terminal] crashed while window resizing

Reported by: diver Owned by: nobody
Priority: normal Milestone: R1
Component: Applications/Terminal Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #6927
Has a Patch: no Platform: All

Description

This is hrev39589, gcc4hybrid.

Thread 131 called debugger(): getNumAvailable() < getNumBlocks() 
[...]
 [Switching to team /boot/system/apps/Terminal less /var/log/syslog (88) thread w>Terminal 1: mc [diver@server]: (131)] 
 0xffff0112 in ?? () 
 (gdb) bt 
 #0  0xffff0112 in ?? () 
 #1  0x00784c6b in debugger () from /boot/system/lib/libroot.so 
 #2  0x0078efc3 in __assert_fail () from /boot/system/lib/libroot.so 
 #3  0x007fa5b9 in BPrivate::hoardHeap::freeBlock () 
    from /boot/system/lib/libroot.so 
    #4  0x007fb93e in BPrivate::processHeap::free () 
       from /boot/system/lib/libroot.so 
       #5  0x007fd0a5 in free () from /boot/system/lib/libroot.so 
       #6  0x0021c09c in BasicTerminalBuffer::_FreeLines () 
       #7  0x0021c42d in BasicTerminalBuffer::_ResizeSimple () 
       #8  0x0021e7b7 in BasicTerminalBuffer::ResizeTo () 
       #9  0x00226490 in TerminalBuffer::ResizeTo () 
       #10 0x0022630a in TerminalBuffer::ResizeTo () 
       #11 0x0023123f in TermView::SetTermSize () 
       #12 0x0023185c in TermView::FrameResized () 
       #13 0x003b60bb in BView::MessageReceived () from /boot/system/lib/libbe.so 
       #14 0x002337a7 in TermView::MessageReceived () 
       #15 0x002fe478 in BLooper::DispatchMessage () from /boot/system/lib/libbe.so 
       #16 0x003c137c in BWindow::DispatchMessage () from /boot/system/lib/libbe.so 
       #17 0x003bcc81 in BWindow::task_looper () from /boot/system/lib/libbe.so 
       #18 0x002ffcda in BLooper::_task0_ () from /boot/system/lib/libbe.so 
       #19 0x00788ac4 in thread_entry () from /boot/system/lib/libroot.so 
       #20 0x700c1fec in ?? () 
       (gdb) 

Change History (6)

comment:1 by Coldfirex, 9 years ago

Possible duplicate of https://dev.haiku-os.org/ticket/6910.

comment:2 by siarzhuk, 6 years ago

Owner: changed from jackburton to siarzhuk
Status: newassigned

comment:3 by siarzhuk, 6 years ago

Owner: changed from siarzhuk to nobody

Could not reproduce the behaviour.

comment:4 by DarkmatterVale, 4 years ago

On the current hrev49675, I could not reproduce this error. I'm running gcc2hybrid, however, so maybe gcc4hybrid will be different.

Can anyone reproduce this error? If not, can we close this bug?

Last edited 4 years ago by DarkmatterVale (previous) (diff)

comment:5 by diver, 4 years ago

Resolution: fixed
Status: assignedclosed

Can't reproduce it either. Assuming fixed.

comment:6 by waddlesplash, 9 months ago

Blocking: 6927 added
Note: See TracTickets for help on using tickets.