Opened 8 years ago

Closed 4 years ago

#6910 closed bug (fixed)

[Terminal] crash in BasicTerminalBuffer::_ResizeRewrap ()

Reported by: diver Owned by: nobody
Priority: normal Milestone: R1
Component: Applications/Terminal Version: R1/Development
Keywords: gci2011 Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev39614 gcc4hybrid.

I resized the Terminal while installing python using installoptionalpackage.

Thread 417 caused an exception: Segment violation 
[...]
[Switching to team /boot/system/apps/Terminal (406) thread w>Terminal 2: home: bash (417)] 
0x0021e4b3 in BasicTerminalBuffer::_ResizeRewrap () 
(gdb) bt 
#0  0x0021e4b3 in BasicTerminalBuffer::_ResizeRewrap () 
#1  0x0021e7c5 in BasicTerminalBuffer::ResizeTo () 
#2  0x00226420 in TerminalBuffer::ResizeTo () 
#3  0x0022630a in TerminalBuffer::ResizeTo () 
#4  0x0023123f in TermView::SetTermSize () 
#5  0x0023185c in TermView::FrameResized () 
#6  0x003b60bb in BView::MessageReceived () from /boot/system/lib/libbe.so 
#7  0x002337a7 in TermView::MessageReceived () 
#8  0x002fe478 in BLooper::DispatchMessage () from /boot/system/lib/libbe.so 
#9  0x003c137c in BWindow::DispatchMessage () from /boot/system/lib/libbe.so 
#10 0x003bcc81 in BWindow::task_looper () from /boot/system/lib/libbe.so 
#11 0x002ffcda in BLooper::_task0_ () from /boot/system/lib/libbe.so 
#12 0x00788ac4 in thread_entry () from /boot/system/lib/libroot.so 
#13 0x700c1fec in ?? () 
(gdb)

Change History (7)

comment:1 Changed 8 years ago by Coldfirex

Possible duplicate of https://dev.haiku-os.org/ticket/6889.

comment:2 Changed 7 years ago by pepol

Keywords: gci2011 added

The problem was checked during GCI 2011. I haven't observed this crash on hrev43238. It seems like https://dev.haiku-os.org/ticket/6889 and https://dev.haiku-os.org/ticket/6927 may be related to it.

comment:3 Changed 7 years ago by diver

hrev44286, this time after resizing Terminal started to hog the cpu. I debugged the thread in question and got exactly the same back trace.

comment:4 Changed 6 years ago by siarzhuk

Owner: changed from jackburton to siarzhuk
Status: newassigned

comment:5 Changed 6 years ago by siarzhuk

Owner: changed from siarzhuk to nobody

Could not reproduce the behaviour.

comment:6 Changed 4 years ago by DarkmatterVale

With the recent incorporation of package management, installoptionalpackage has been deprecated and removed. This issue should therefore be closed.

comment:7 Changed 4 years ago by diver

Resolution: fixed
Status: assignedclosed

The fact that there's no installoptionalpackage script anymore doesn't make this ticket invalid. However, I wasn't able to reproduce this crash, so I assume it was fixed in the meantime.

Note: See TracTickets for help on using tickets.