Opened 10 years ago

Closed 4 years ago

#7031 closed bug (duplicate)

IPP transport addon advertises ability to detect ports

Reported by: myob Owned by: nobody
Priority: normal Milestone: R1
Component: Printing Version: R1/alpha2
Keywords: Cc: phoudoin
Blocked By: #12702 Blocking:
Platform: All

Description

The IPP printer addon advertises the ability to detect ports, there isn't any such ability (you enter the IPP URL manually the first time you print). You can't add an IPP printer due to this as you can't select the transport

Lines 197 to 201 in ipp.cpp seem to be the culprit here, looks as if the code was put there expecting some form of service discovery in future that wasn't implemented.

Change History (5)

comment:1 by laplace, 10 years ago

Cc: phoudoin added

comment:2 by humdinger, 8 years ago

Owner: changed from laplace to nobody
Status: newassigned

comment:3 by kallisti5, 5 years ago

I just got a generic Xerox postscript network printer.. might take a crack at this one.. CUPS does detect the printer on the network.. need to dig into this. At minimum we need to have the ability to specify the ipp://printer URL manually (the printer preflet seems to depend on automatic discovery)

comment:4 by vidrep, 4 years ago

This is a duplicate of ticket #12702.

comment:5 by diver, 4 years ago

Blocked By: 12702 added
Resolution: duplicate
Status: assignedclosed
Note: See TracTickets for help on using tickets.