Opened 9 years ago

Closed 11 months ago

#7042 closed bug (fixed)

[Network Stack] PANIC: Hash Table: value already in table

Reported by: diver Owned by: nobody
Priority: normal Milestone: R1
Component: Network & Internet/Stack Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev39984, gcc4hybrid.

Running this command several times crashes kernel:

ifconfig del /dev/net/ipro1000/0 ; ifconfig /dev/net/ipro1000/0 up

Attachments (2)

panic.png (38.3 KB) - added by diver 9 years ago.
panic_hrev47314.png (117.3 KB) - added by diver 5 years ago.

Download all attachments as: .zip

Change History (12)

Changed 9 years ago by diver

Attachment: panic.png added

Changed 5 years ago by diver

Attachment: panic_hrev47314.png added

comment:1 Changed 5 years ago by diver

This is with hrev47314.

comment:2 Changed 5 years ago by jackburton

I just tried under vbox (hrev47724), and couldn't get a KDL. Diver, could you recheck ?

Last edited 5 years ago by jackburton (previous) (diff)

comment:3 Changed 5 years ago by diver

hrev47724 as well here. Get the same panic as above.

comment:4 Changed 5 years ago by jackburton

Which version of VirtualBox ? How is the NIC configured ? Here 4.3.10, NIC configured in "NAT" mode.

comment:5 Changed 5 years ago by diver

VBoxManage showvminfo Haiku | grep NIC.1
NIC 1:           MAC: 0800273A9807, Attachment: NAT, Cable connected: on, Trace: off (file: none), Type: 82540EM, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: deny
NIC 1 Settings:  MTU: 0, Socket (send: 64, receive: 64), TCP Window (send:64, receive: 64)

VBoxManage --version
4.1.28r89849

comment:6 Changed 5 years ago by jackburton

I can reproduce the deadlock every time, but not the KDL. I wonder if it depends on the number of cpu assigned to the VM... 1 cpu here.

comment:7 Changed 5 years ago by diver

1 cpu here as well.

comment:8 Changed 2 years ago by axeld

Owner: changed from axeld to nobody
Status: newassigned

comment:9 Changed 11 months ago by jackburton

The backtrace looks identical to the one in #10919, and is no longer related to the ticket description. Shall we close this as duplicated ?

comment:10 Changed 11 months ago by diver

Resolution: fixed
Status: assignedclosed

The second backtrace is indeed a dupe of #10919. Closing in hope that original problem was fixed in the meantime.

Note: See TracTickets for help on using tickets.