Opened 9 years ago

Last modified 6 years ago

#7050 assigned bug

BGLView /OpenGL resize bug when direct mode is enabled

Reported by: jackburton Owned by: kallisti5
Priority: normal Milestone: R1
Component: Kits/OpenGL Kit Version: R1/Development
Keywords: Cc:
Blocked By: #6614 Blocking:
Has a Patch: no Platform: All

Description

Launch GLTeapot, grab the resize knob, and start resizing the window very fast lots of times. After a while the application will hang. Reproducible on VirtualBox, didn't try yet on real hardware.

Change History (10)

comment:1 Changed 9 years ago by the ringmaster

happens for me as well. When I grab and flail the handle, the teapot window goes black and the window is unresponsive. Rev 40042

comment:2 Changed 9 years ago by jscipione

I've noticed the same thing happening if you move the window around wildly as well. Grab the window and move it around vigorously. Eventually the teapot will stop rendering inside the view and the app will crash and need to be killed.

comment:3 Changed 9 years ago by stargatefan

heh, does the teapot image still detach from the windo if you resize after you move it ? I was gonna file a bug report for this months ago but opengl is pretty low on the totem pole as I gather.

comment:4 Changed 9 years ago by jackburton

Summary: BGLView /OpenGL resize bugBGLView /OpenGL resize bug when direct mode is enabled

The bug only shows up when direct mode is enabled. I think what happens is that BGLView::FrameResized() and BGLView::DirectConnected() are interacting in bad ways: FrameResized() is triggered asynchronously by a BMessage, while DirectConnected() is called by releasing a semaphore by the app_server (still asynchronously, though). In both these functions we change some member variables which are closely connected and depends one on the other (fBounds and the direct_buffer_info stuff).

Last edited 9 years ago by jackburton (previous) (diff)

comment:5 in reply to:  3 ; Changed 9 years ago by Disreali

Replying to stargatefan:

heh, does the teapot image still detach from the windo if you resize after you move it ? I was gonna file a bug report for this months ago but opengl is pretty low on the totem pole as I gather.

That has already been reported on #6614.

jackburton, Is it possible that these two issues are related?

comment:6 in reply to:  5 Changed 9 years ago by jackburton

Replying to Disreali:

That has already been reported on #6614.

jackburton, Is it possible that these two issues are related?

Yes, they are definitely related, both are caused by the non-defined order in which DirectConnected() and FrameResized() can be called.

comment:7 Changed 8 years ago by jackburton

Blocked By: 6614 added
Resolution: duplicate
Status: newclosed

comment:8 Changed 8 years ago by jackburton

Resolution: duplicate
Status: closedreopened

Reopening, since the symptoms are different (but the cause is the same)

comment:9 Changed 6 years ago by kallisti5

Is this still an issue as of R1A4?

comment:10 Changed 6 years ago by kallisti5

Owner: changed from korli to kallisti5
Status: reopenedassigned
Note: See TracTickets for help on using tickets.