Opened 9 years ago

Closed 9 years ago

#7049 closed bug (fixed)

"installoptionalpackage man" fails

Reported by: BMeow Owned by: mmadia
Priority: normal Milestone: R1
Component: Applications/Command Line Tools Version: R1/Development
Keywords: installoptionalpackage man Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

On hrev40033-x86gcc2hybrid, reproducible in Qemu and on real hardware:

~> installoptionalpackage man
Generating a list of Package Names ...
To be installed:  Man Groff 
Installing man-1.6f-x86-gcc2-2010-09-01.zip ...
Downloading http://haiku-files.org/files/optional-packages/man-1.6f-x86-gcc2-2010-09-01.zip ...
2010-12-30 10:45:43 URL:http://haiku-files.org/files/optional-packages/man-1.6f-x86-gcc2-2010-09-01.zip [44675/44675] -> "man-1.6f-x86-gcc2-2010-09-01.zip" [1]
Extracting man-1.6f-x86-gcc2-2010-09-01.zip ...
/boot/common/cache/tmp/install-optpkg.sh: line 283: syntax error near unexpected token `fi'
/boot/common/cache/tmp/install-optpkg.sh: line 283: `fi'
... something went wrong when installing packages.

Change History (4)

comment:1 by mmadia, 9 years ago

Owner: changed from nobody to mmadia
Status: newassigned

I'll look into this.

comment:2 by stargatefan, 9 years ago

https://dev.haiku-os.org/ticket/7033

likely related, I got a similar error before gdb.

comment:3 by mmadia, 9 years ago

Status: assignedin-progress

This is caused by a failure in installoptionalpackage's use of sed. Filtering OptionalPackages for "Man" also pulls in "MandatoryPackages".

comment:4 by mmadia, 9 years ago

Resolution: fixed
Status: in-progressclosed

fixed in hrev40047.

Note: See TracTickets for help on using tickets.