Opened 9 years ago

Closed 4 years ago

#7095 closed bug (duplicate)

[ShowImage] crashes in conversion::convert_from_CMYK_to_32

Reported by: diver Owned by: leavengood
Priority: normal Milestone: R1
Component: Applications/ShowImage Version: R1/Development
Keywords: Cc:
Blocked By: #8902 Blocking:
Has a Patch: no Platform: All

Description

This is hrev40208, gcc4hybrid.

If I close ShowImage quicky after opening 2,7mb photo it crashes.
If I open the same image and wait several seconds before closing it - then it closes without crashing.

Thread 662 caused an exception: Segment violation
[...]
[Switching to team /boot/system/apps/ShowImage (653) thread image loader (662)]
0xffff012c in ?? ()
(gdb) bt
#0  0xffff012c in ?? ()
#1  0x01d15d07 in conversion::convert_from_CMYK_to_32 ()
   from /boot/system/add-ons/Translators/JPEGTranslator
#2  0x0040b358 in BPositionIO::Write () from /boot/system/lib/libbe.so
#3  0x01d125e1 in JPEGTranslator::Decompress ()
   from /boot/system/add-ons/Translators/JPEGTranslator
#4  0x01d1313e in JPEGTranslator::DerivedTranslate ()
   from /boot/system/add-ons/Translators/JPEGTranslator
#5  0x01d166d2 in BaseTranslator::BitsTranslate ()
   from /boot/system/add-ons/Translators/JPEGTranslator
#6  0x01d1671a in BaseTranslator::Translate ()
   from /boot/system/add-ons/Translators/JPEGTranslator
#7  0x00645286 in BTranslatorRoster::Translate ()
   from /boot/system/lib/libtranslation.so
#8  0x00218a49 in ImageCache::_RetrieveImage ()
#9  0x0021920f in ImageCache::_QueueWorkerThread ()
#10 0x0079d060 in thread_entry () from /boot/system/lib/libroot.so
#11 0x700c1fec in ?? ()
(gdb)
}

Change History (8)

comment:1 Changed 9 years ago by diver

I copied this image to another folder and now ShowImage doesn't crash anymore.
I copied second image to the same folder and crash reappeared.
Then I deleted both of them and copied yet another image to that folder - no crash. Then I copied /boot/system/data/artwork/HAIKU logo - white on blue - big.png to that folder and crash reappeared again, but only after opening and quickly closing HAIKU logo - white on blue - big.png file.

Last edited 9 years ago by diver (previous) (diff)

comment:2 Changed 9 years ago by diver

Looks like something is wrong with background preloading of big images.

comment:3 Changed 8 years ago by halilpk

(GCI-2011 Participant)

Haiku revision: hrev42211 not a bug. I have tried it over 4mb image files and there was no problem to close . System: Haiku hrev1-alpha3 on VMware workstation 8 on windows 7 32 bit

comment:4 Changed 7 years ago by hometue

(GCI-2012 Participant) Haiku revision: hrev44702. Not valid, I have tried with duplicates of an image 5.81mb big and it does not crash even when closed quickly. System: Haiku R1-alpha4 on Virtualbox 4.1.20 on windows 7 64 bit

comment:5 Changed 5 years ago by pulkomandy

For the crash to happen you need a CMYK JPEG picture in the folder it would seem (or else I don't see how you would end up with that backtrace).

I found one such file: http://upload.wikimedia.org/wikipedia/en/2/25/Channel_digital_image_CMYK_color.jpg

Currently ShowImage doesn't render it at all. Qupzilla and Web+ do.

comment:6 Changed 5 years ago by pulkomandy

Mh, I tried that image again and now it displays just fine. Could have been a problem with my installed system then. No crash with it in any case.

comment:7 Changed 4 years ago by Janus

This is a duplicate of #8902

comment:8 Changed 4 years ago by pulkomandy

Blocked By: 8902 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.