Opened 9 years ago

Closed 6 years ago

#7096 closed bug (fixed)

HP JetDirect addon not functioning in (at least) some circumstances, possibly Gutenprint related

Reported by: myob Owned by: nobody
Priority: normal Milestone: R1
Component: Printing Version: R1/alpha2
Keywords: Cc: bug5lay4r@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I've a HP Photosmart B110a that can be driven for extremely basic, A4 B&W or colour printing using a HP Deskjet 1200 or 1220c. This works 100% under Haiku with Gutenprint on a USB connection once the margin issues in #7032 are taken in to consideration

However, its a network printer and presents a JetDirect port which works under Windows/MacOS X. When the same Gutenprint driver is set up to print to JetDirect, the printer will get no further than feeding a sheet to the print heads, and will sit there with "printing" scrolling on its LCD indefinitely.

If you tell a PCL5 or 6 driver to run over Jetdirect, they'll cause gibberish to be printed, which is to be expected as the printer supports PCL3GUI and no higher (despite being a 2010 model), so there's no overall failure to operate.

Change History (5)

comment:1 by laplace, 9 years ago

AFAICT HP JetDirect should not have worked at all, because it always did use 0 instead of the specified port. The problem with the wrong port number is fixed in hrev40278.

comment:2 by humdinger, 8 years ago

Owner: changed from laplace to nobody
Status: newassigned

Is this still valid?

comment:3 by zzzzz, 7 years ago

Cc: bug5lay4r@… added

comment:4 by cian, 6 years ago

Working on A4.1 with a B210a (the b110a bit the dust).

comment:5 by axeld, 6 years ago

Resolution: fixed
Status: assignedclosed

Thanks for the note!

Note: See TracTickets for help on using tickets.