Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7179 closed bug (fixed)

Tracker crash on block device HVIF icon replacement

Reported by: kallisti5 Owned by: anevilyak
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by kallisti5)

  • Bring up the "Get info" window for a hard drive on the desktop.
  • Drag the "Device_Harddisk_development" HVIF file from haiku/data/artwork/icons onto the drive icon
  • Tracker crash

Change History (7)

comment:1 by kallisti5, 9 years ago

 [Switching to team /boot/system/Tracker (111) thread w>Data info (1030)]
0x00573eb6 in BPrivate::BPoseView::MoveSelectionInto ()
   from /boot/system/lib/libtracker.so
(gdb) bt
#0  0x00573eb6 in BPrivate::BPoseView::MoveSelectionInto ()
   from /boot/system/lib/libtracker.so
#1  0x0057d8c7 in BPrivate::BPoseView::HandleDropCommon ()
   from /boot/system/lib/libtracker.so
#2  0x0054da9b in BPrivate::AttributeView::MessageReceived ()
   from /boot/system/lib/libtracker.so
#3  0x002c9918 in BLooper::DispatchMessage () from /boot/system/lib/libbe.so
#4  0x0038c8ec in BWindow::DispatchMessage () from /boot/system/lib/libbe.so
#5  0x003881f1 in BWindow::task_looper () from /boot/system/lib/libbe.so
#6  0x002cb17a in BLooper::_task0_ () from /boot/system/lib/libbe.so
#7  0x00634060 in thread_entry () from /boot/system/lib/libroot.so
#8  0x7003ffec in ?? ()

comment:2 by kallisti5, 9 years ago

Description: modified (diff)
Summary: Tracker crash on hard drive icon dragTracker crash on block device HVIF icon replacement

comment:3 by anevilyak, 9 years ago

Owner: changed from axeld to anevilyak
Status: newin-progress

comment:4 by anevilyak, 9 years ago

Resolution: fixed
Status: in-progressclosed

Fixed in hrev40338.

in reply to:  4 ; comment:5 by jackburton, 9 years ago

Replying to anevilyak:

Fixed in hrev40338.

I think that this removes a feature: dragging a file into a "get info window" of a symlink would link it to the dragged file. This was particularily useful to restore broken links.

in reply to:  5 comment:6 by anevilyak, 9 years ago

Replying to jackburton:

I think that this removes a feature: dragging a file into a "get info window" of a symlink would link it to the dragged file. This was particularily useful to restore broken links.

Will look into it after work, but I believe that feature follows a different code path, the one I fixed was more or less 100% guaranteed to crash if the target wasn't a container window with a pose view, since the destWindow pointer passed to MoveSelectionInto in that case was NULL, and the function proceeded to unconditionally call a number of accessors on said window pointer.

in reply to:  5 comment:7 by anevilyak, 9 years ago

Replying to jackburton:

I think that this removes a feature: dragging a file into a "get info window" of a symlink would link it to the dragged file. This was particularily useful to restore broken links.

Verified that the mentioned feature still works as intended.

Note: See TracTickets for help on using tickets.