Opened 9 years ago

Closed 4 years ago

#7178 closed bug (fixed)

BEAE crashing media server

Reported by: stargatefan Owned by: nobody
Priority: normal Milestone: R1
Component: Applications Version: R1/alpha2
Keywords: BEAE media server Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

BeAE is crashing audio server. It seems to lock up the mixer control thread. I tried to get a screen shot. Here is the bt and primary info I was able to gather from gdb land.

GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i586-pc-haiku"...(no debugging symbols found)

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Thread 2316 caused an exception: Segment violation
Reading symbols from /boot/system/runtime_loader...done.
Loaded symbols for /boot/system/runtime_loader
Reading symbols from /boot/system/lib/libbe.so...done.
Loaded symbols for /boot/system/lib/libbe.so
Reading symbols from /boot/system/lib/libroot.so...done.
Loaded symbols for /boot/system/lib/libroot.so
Reading symbols from /boot/system/lib/libtracker.so...done.
Loaded symbols for /boot/system/lib/libtracker.so
Reading symbols from /boot/system/lib/libmedia.so...done.
Loaded symbols for /boot/system/lib/libmedia.so
Reading symbols from /boot/system/lib/libtranslation.so...done.
Loaded symbols for /boot/system/lib/libtranslation.so
Reading symbols from /boot/system/lib/libgame.so...done.
Loaded symbols for /boot/system/lib/libgame.so
Reading symbols from /boot/system/lib/libstdc++.so...done.
Loaded symbols for /boot/system/lib/libstdc++.so
Reading symbols from /boot/system/lib/liblocale.so...done.
Loaded symbols for /boot/system/lib/liblocale.so
Reading symbols from /boot/system/lib/libsupc++.so...done.
Loaded symbols for /boot/system/lib/libsupc++.so
Reading symbols from /boot/system/lib/libtextencoding.so...done.
Loaded symbols for /boot/system/lib/libtextencoding.so
Reading symbols from /boot/system/lib/libicudata.so.44...
warning: Lowest section in /boot/system/lib/libicudata.so.44 is .hash at 00000094
done.
Loaded symbols for /boot/system/lib/libicudata.so.44
Reading symbols from /boot/system/lib/libicui18n.so.44...done.
Loaded symbols for /boot/system/lib/libicui18n.so.44
Reading symbols from /boot/system/lib/libicuio.so.44...done.
Loaded symbols for /boot/system/lib/libicuio.so.44
Reading symbols from /boot/system/lib/libicule.so.44...done.
Loaded symbols for /boot/system/lib/libicule.so.44
Reading symbols from /boot/system/lib/libiculx.so.44...done.
Loaded symbols for /boot/system/lib/libiculx.so.44
Reading symbols from /boot/system/lib/libicutu.so.44...done.
Loaded symbols for /boot/system/lib/libicutu.so.44
Reading symbols from /boot/system/lib/libicuuc.so.44...done.
Loaded symbols for /boot/system/lib/libicuuc.so.44
Reading symbols from /boot/system/lib/libroot-addon-icu.so...done.
Loaded symbols for /boot/system/lib/libroot-addon-icu.so
Reading symbols from /boot/system/add-ons/Translators/BMPTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/BMPTranslator
Reading symbols from /boot/system/add-ons/Translators/EXRTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/EXRTranslator
Reading symbols from /boot/system/lib/libilmimf.so...done.
Loaded symbols for /boot/system/lib/libilmimf.so
Reading symbols from /boot/system/lib/libz.so.1...done.
Loaded symbols for /boot/system/lib/libz.so.1
Reading symbols from /boot/system/add-ons/Translators/GIFTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/GIFTranslator
Reading symbols from /boot/system/add-ons/Translators/HVIFTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/HVIFTranslator
Reading symbols from /boot/system/add-ons/Translators/ICOTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/ICOTranslator
Reading symbols from /boot/system/add-ons/Translators/JPEG2000Translator...done.
Loaded symbols for /boot/system/add-ons/Translators/JPEG2000Translator
Reading symbols from /boot/system/add-ons/Translators/JPEGTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/JPEGTranslator
Reading symbols from /boot/system/lib/libjpeg.so.8.0...done.
Loaded symbols for /boot/system/lib/libjpeg.so.8.0
Reading symbols from /boot/system/add-ons/Translators/PCXTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/PCXTranslator
Reading symbols from /boot/system/add-ons/Translators/PNGTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/PNGTranslator
Reading symbols from /boot/system/lib/libpng.so.1.4...done.
Loaded symbols for /boot/system/lib/libpng.so.1.4
Reading symbols from /boot/system/add-ons/Translators/PPMTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/PPMTranslator
Reading symbols from /boot/system/add-ons/Translators/RAWTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/RAWTranslator
Reading symbols from /boot/system/add-ons/Translators/RTF-Translator...done.
Loaded symbols for /boot/system/add-ons/Translators/RTF-Translator
Reading symbols from /boot/system/add-ons/Translators/SGITranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/SGITranslator
Reading symbols from /boot/system/add-ons/Translators/STXTTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/STXTTranslator
Reading symbols from /boot/system/add-ons/Translators/TGATranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/TGATranslator
Reading symbols from /boot/system/add-ons/Translators/TIFFTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/TIFFTranslator
Reading symbols from /boot/system/lib/libtiff.so.3.8...done.
Loaded symbols for /boot/system/lib/libtiff.so.3.8
Reading symbols from /boot/system/add-ons/Translators/WebPTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/WebPTranslator
Reading symbols from /boot/system/add-ons/Translators/WonderBrushTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/WonderBrushTranslator
Reading symbols from /boot/system/add-ons/media/mixer.media_addon...done.
Loaded symbols for /boot/system/add-ons/media/mixer.media_addon
Reading symbols from /boot/system/add-ons/media/plugins/ffmpeg...done.
Loaded symbols for /boot/system/add-ons/media/plugins/ffmpeg
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/apps/BeAE/BeAE (2316) thread BeAE (2316)]
0x00000000 in ?? ()
(gdb) bt
#0  0x00000000 in ?? ()
#1  0x0028b2a2 in MyApplication::QuitRequested ()
#2  0x0036a7f1 in BLooper::_QuitRequested () from /boot/system/lib/libbe.so
#3  0x0036a909 in BLooper::DispatchMessage () from /boot/system/lib/libbe.so
#4  0x00361b6b in BApplication::DispatchMessage ()
   from /boot/system/lib/libbe.so
#5  0x0036c454 in BLooper::task_looper () from /boot/system/lib/libbe.so
#6  0x00362044 in BApplication::Run () from /boot/system/lib/libbe.so
#7  0x0028b5a6 in main ()
(gdb) 


Change History (9)

comment:1 by anevilyak, 9 years ago

That gdb info appears to simply show BeAE itself crashing while shutting down.

comment:2 by stargatefan, 9 years ago

Component: - GeneralApplications
Keywords: BEAE media server added

comment:3 by stargatefan, 9 years ago

gcc4 hybrid 40265 BEAE does not play the file either, merely starting the program brings the media server to its knees.

If this is a problem I am expericnecing I will try a reinstall first. But all other media apps work fine. It also blocks media player from functioning as well.Restart of the media server does resolve the issue.

in reply to:  1 comment:4 by stargatefan, 9 years ago

Replying to anevilyak:

That gdb info appears to simply show BeAE itself crashing while shutting down.

Thats all the info I have, however try using it and see if you can reproduce the bugs ?

comment:5 by stargatefan, 9 years ago

hopefully this will be a bit more helpful. gnash,beae and a few other program have trouble with the mixer thread. Like lock contention or something stupid.

GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i586-pc-haiku"...(no debugging symbols found)

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Reading symbols from /boot/system/runtime_loader...done.
Loaded symbols for /boot/system/runtime_loader
Reading symbols from /boot/system/lib/libbe.so...done.
Loaded symbols for /boot/system/lib/libbe.so
Reading symbols from /boot/system/lib/libroot.so...done.
Loaded symbols for /boot/system/lib/libroot.so
Reading symbols from /boot/system/lib/libtracker.so...done.
Loaded symbols for /boot/system/lib/libtracker.so
Reading symbols from /boot/system/lib/libmedia.so...done.
Loaded symbols for /boot/system/lib/libmedia.so
Reading symbols from /boot/system/lib/libtranslation.so...done.
Loaded symbols for /boot/system/lib/libtranslation.so
Reading symbols from /boot/system/lib/libgame.so...done.
Loaded symbols for /boot/system/lib/libgame.so
Reading symbols from /boot/system/lib/libstdc++.so...done.
Loaded symbols for /boot/system/lib/libstdc++.so
Reading symbols from /boot/system/lib/liblocale.so...done.
Loaded symbols for /boot/system/lib/liblocale.so
Reading symbols from /boot/system/lib/libsupc++.so...done.
Loaded symbols for /boot/system/lib/libsupc++.so
Reading symbols from /boot/system/lib/libtextencoding.so...done.
Loaded symbols for /boot/system/lib/libtextencoding.so
Reading symbols from /boot/system/lib/libicudata.so.44...
warning: Lowest section in /boot/system/lib/libicudata.so.44 is .hash at 00000094
done.
Loaded symbols for /boot/system/lib/libicudata.so.44
Reading symbols from /boot/system/lib/libicui18n.so.44...done.
Loaded symbols for /boot/system/lib/libicui18n.so.44
Reading symbols from /boot/system/lib/libicuio.so.44...done.
Loaded symbols for /boot/system/lib/libicuio.so.44
Reading symbols from /boot/system/lib/libicule.so.44...done.
Loaded symbols for /boot/system/lib/libicule.so.44
Reading symbols from /boot/system/lib/libiculx.so.44...done.
Loaded symbols for /boot/system/lib/libiculx.so.44
Reading symbols from /boot/system/lib/libicutu.so.44...done.
Loaded symbols for /boot/system/lib/libicutu.so.44
Reading symbols from /boot/system/lib/libicuuc.so.44...done.
Loaded symbols for /boot/system/lib/libicuuc.so.44
Reading symbols from /boot/system/lib/libroot-addon-icu.so...done.
Loaded symbols for /boot/system/lib/libroot-addon-icu.so
Reading symbols from /boot/system/add-ons/Translators/BMPTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/BMPTranslator
Reading symbols from /boot/system/add-ons/Translators/EXRTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/EXRTranslator
Reading symbols from /boot/system/lib/libilmimf.so...done.
Loaded symbols for /boot/system/lib/libilmimf.so
Reading symbols from /boot/system/lib/libz.so.1...done.
Loaded symbols for /boot/system/lib/libz.so.1
Reading symbols from /boot/system/add-ons/Translators/GIFTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/GIFTranslator
Reading symbols from /boot/system/add-ons/Translators/HVIFTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/HVIFTranslator
Reading symbols from /boot/system/add-ons/Translators/ICOTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/ICOTranslator
Reading symbols from /boot/system/add-ons/Translators/JPEG2000Translator...done.
Loaded symbols for /boot/system/add-ons/Translators/JPEG2000Translator
Reading symbols from /boot/system/add-ons/Translators/JPEGTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/JPEGTranslator
Reading symbols from /boot/system/lib/libjpeg.so.8.0...done.
Loaded symbols for /boot/system/lib/libjpeg.so.8.0
Reading symbols from /boot/system/add-ons/Translators/PCXTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/PCXTranslator
Reading symbols from /boot/system/add-ons/Translators/PNGTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/PNGTranslator
Reading symbols from /boot/system/lib/libpng.so.1.4...done.
Loaded symbols for /boot/system/lib/libpng.so.1.4
Reading symbols from /boot/system/add-ons/Translators/PPMTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/PPMTranslator
Reading symbols from /boot/system/add-ons/Translators/RAWTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/RAWTranslator
Reading symbols from /boot/system/add-ons/Translators/RTF-Translator...done.
Loaded symbols for /boot/system/add-ons/Translators/RTF-Translator
Reading symbols from /boot/system/add-ons/Translators/SGITranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/SGITranslator
Reading symbols from /boot/system/add-ons/Translators/STXTTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/STXTTranslator
Reading symbols from /boot/system/add-ons/Translators/TGATranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/TGATranslator
Reading symbols from /boot/system/add-ons/Translators/TIFFTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/TIFFTranslator
Reading symbols from /boot/system/lib/libtiff.so.3.8...done.
Loaded symbols for /boot/system/lib/libtiff.so.3.8
Reading symbols from /boot/system/add-ons/Translators/WebPTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/WebPTranslator
Reading symbols from /boot/system/add-ons/Translators/WonderBrushTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/WonderBrushTranslator
Reading symbols from /boot/system/add-ons/media/mixer.media_addon...done.
Loaded symbols for /boot/system/add-ons/media/mixer.media_addon
Reading symbols from /boot/system/add-ons/media/plugins/ffmpeg...done.
Loaded symbols for /boot/system/add-ons/media/plugins/ffmpeg
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/apps/BeAE/BeAE (607) thread Audio Mixer control (636)]
0xffff0114 in ?? ()
(gdb) bt
#0  0xffff0114 in ?? ()
#1  0x00545a8c in acquire_sem_etc () from /boot/system/lib/libroot.so
#2  0x0047df88 in BLocker::AcquireLock () from /boot/system/lib/libbe.so
#3  0x0047e01e in BLocker::Lock () from /boot/system/lib/libbe.so
#4  0x01fb4ce8 in AudioMixer::PublishEventLatencyChange ()
   from /boot/system/add-ons/media/mixer.media_addon
#5  0x01fb502f in AudioMixer::LateNoticeReceived ()
   from /boot/system/add-ons/media/mixer.media_addon
#6  0x007e4b7d in BBufferProducer::HandleMessage ()
   from /boot/system/lib/libmedia.so
#7  0x007f0c02 in BMediaNode::WaitForMessage ()
   from /boot/system/lib/libmedia.so
#8  0x007eb97e in BMediaEventLooper::ControlLoop ()
   from /boot/system/lib/libmedia.so
#9  0x007eb3a9 in BMediaEventLooper::_ControlThreadStart ()
   from /boot/system/lib/libmedia.so
#10 0x00546070 in thread_entry () from /boot/system/lib/libroot.so
#11 0x78288fec in ?? ()
(gdb) 

comment:6 by pulkomandy, 5 years ago

Installed BeAE from HaikuDepot, did not get this problem. It did crash on exit for a different reason, however.

Can you still reproduce?

comment:7 by waddlesplash, 5 years ago

Edited some media files with BeAE, didn't crash the media_server. Can't reproduce either.

comment:8 by Barrett, 4 years ago

Can't reproduce it too, since 2013 or so.

comment:9 by Barrett, 4 years ago

Resolution: fixed
Status: newclosed

Marking as fixed as it seems not happening anymore.

Note: See TracTickets for help on using tickets.