Opened 9 years ago

Closed 7 years ago

#7197 closed bug (fixed)

Apple Mac Mini 2010 with NO Ethernet Networking

Reported by: macsociety Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/Network/broadcom570x Version: R1/alpha2
Keywords: Ethernet Not Detected Apple Mac Mini 2010 Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Have a Mac Mini 2010 model that built in Ethernet Port is not being detected in Network Prefences of Haiku. So, can't get on the Internet as it sits. I was able to connect a USB Ethernet Adapter to the Mac Mini to connect to the Net but would prefer using built in Ethernet Port if possible. That way I don't gave a big USB Ethernet Adapter always connected.

Attachments (3)

ListDevTJFerreira (3.3 KB ) - added by macsociety 9 years ago.
ListDev that shows my devices on Mac Min 2010 for TJ Ferreira
NetworkPrefError (2.4 KB ) - added by macsociety 9 years ago.
Network Error when trying to go to network preferences
syslog copy (254.6 KB ) - added by macsociety 9 years ago.
My Sys Log

Download all attachments as: .zip

Change History (10)

by macsociety, 9 years ago

Attachment: ListDevTJFerreira added

ListDev that shows my devices on Mac Min 2010 for TJ Ferreira

comment:1 by mmadia, 9 years ago

Could you retest this and #7196 with a newer nightly-image? http://www.haiku-files.org

in reply to:  1 comment:2 by macsociety, 9 years ago

Replying to mmadia:

Could you retest this and #7196 with a newer nightly-image? http://www.haiku-files.org

Downloaded and created a fresh install on a USB Thumb Drive the Nightly Build from Feb 4th. Boots my Mac Mini fine. Still no sound or network. In fact, new errors arose. With ethernet cable connected to built in ethernet port and then selecting Network Preferences, I got an error screen. Said "The application /boot/system/preferences/network has encountered an error....." I then sent the debug screen to my monitor and saved the text it had. I have attached that text to my attachments. I then rebooted with the inland USB Ethernet Adapter connected to the Mac Mini instead and now the nework preference does come up and it appears it grabbed an IP via DHCP but since Web Positive is no longer in your nightly build, was unable to see if I could browse the web. But, network preference did not like my ethernet cable connected to built in ethernet port and error popped up. I also am attaching a Sys Log in hopes this helps the cause. Thanks, TJ

by macsociety, 9 years ago

Attachment: NetworkPrefError added

Network Error when trying to go to network preferences

by macsociety, 9 years ago

Attachment: syslog copy added

My Sys Log

comment:3 by macsociety, 9 years ago

Component: Network & InternetDrivers/Network

comment:4 by tonestone57, 9 years ago

His integrated network card is:

device Network controller (Ethernet controller) [2|0|0]
vendor 14e4: Broadcom Corporation
device 16b4: NetXtreme BCM57765 Gigabit Ethernet PCIe

Haiku's Broadcom BSD network driver needs updating to latest.

I did not see his card listed in Haiku's broadcom driver. I also don't believe FreeBSD has it either but NetBSD should have it.

http://www.mail-archive.com/search?q=BCM57765&l=source-changes-full%40netbsd.org

comment:5 by korli, 9 years ago

This will have to wait on support for this device by FreeBSD (OpenBSD has it).

in reply to:  5 comment:6 by tonestone57, 9 years ago

Replying to korli:

This will have to wait on support for this device by FreeBSD (OpenBSD has it).

OpenBSD added support for this network card 13 months back. OpenBSD made additional changes and fixes to their bge driver 7 months back to better support BCM57765.

http://www.openbsd.org/cgi-bin/cvsweb/src/sys/dev/pci/if_bge.c

Makes me wonder why FreeBSD has not added support for this network card yet. FreeBSD should rethink their driver updating policy when another BSD beats them by 6+ months in supporting newer hardware.

comment:7 by diver, 7 years ago

Component: Drivers/NetworkDrivers/Network/broadcom570x
Resolution: fixed
Status: newclosed

Should be fixed since hrev43729.

Note: See TracTickets for help on using tickets.