Opened 8 years ago

Closed 7 years ago

#7198 closed bug (fixed)

CdRecord does not detect LiteOn DH16A1S OEM SATA DVD burner

Reported by: Disreali Owned by: nobody
Priority: normal Milestone: R1
Component: Applications/Command Line Tools Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

On a fresh Alpha-profile install, BurnItNow claims that no devices are available yet DriveSetup shows the DVD burner at /dev/disk/scsi/0/5/0/raw.

Experienced on hrev40364-2h, though it has always been an issue on this system.

Attachments (3)

r40364-2h_burnitnow_not_detecting_CDBurner.png (98.2 KB) - added by Disreali 8 years ago.
r40364_devices_dvdrom_info.png (73.3 KB) - added by Disreali 8 years ago.
acer-am5620_listedev.txt (3.2 KB) - added by Disreali 8 years ago.

Download all attachments as: .zip

Change History (13)

Changed 8 years ago by Disreali

Changed 8 years ago by Disreali

Changed 8 years ago by Disreali

Attachment: acer-am5620_listedev.txt added

comment:1 Changed 8 years ago by scottmc

can you post the output of "cdrecord -checkdrive" as well?

comment:2 Changed 8 years ago by scottmc

Can you try cdrtools-3.01a01 and see if that shows anything different? http://ports-space.haiku-files.org/app-cdr/

comment:3 in reply to:  2 Changed 8 years ago by Disreali

Replying to scottmc:

Can you try cdrtools-3.01a01 and see if that shows anything different?

That version of cdrecord is install by default on hrev41098-4h. Installed BurnItNow via installoptinalpackage script.

Requested output:

/boot/home> cdrecord --version
Cdrecord-ProDVD-ProBD-Clone 3.01a01 (i586-pc-haiku) Copyright (C) 1995-2010 Jg Schilling
/boot/home> cdrecord -checkdrive
Cdrecord-ProDVD-ProBD-Clone 3.01a01 (i586-pc-haiku) Copyright (C) 1995-2010 Jg Schilling
Using libscg version 'schily-0.9'.
No target specified, trying to find one...
cdrecord: No target found.
cdrecord: No target found.
cdrecord: No CD/DVD/BD-Recorder target found.
cdrecord: Your platform may not allow to scan for SCSI devices.
cdrecord: Call 'cdrecord dev=help' or ask your sysadmin for possible targets.
/boot/home> cdrecord dev=help
Cdrecord-ProDVD-ProBD-Clone 3.01a01 (i586-pc-haiku) Copyright (C) 1995-2010 Jg Schilling
Supported SCSI transports for this platform:

Transport name:         CAM
Transport descr.:       Generic transport independent SCSI (BeOS CAM variant)
Transp. layer ind.:     
Target specifier:       bus,target,lun
Target example:         1,2,0
SCSI Bus scanning:      supported
Open via UNIX device:   not supported

Looks like it is a CdRecord issue. I have determined that my dvd-drive is a Lite-On OEM version and that may be where the issue is.

comment:4 Changed 8 years ago by Disreali

Summary: BurnItNow does not detect SATA DVD burnerCdRecord does not detect LiteOn DH16A1S OEM SATA DVD burner

Modified ticket summery to reflect actual issue.

comment:5 Changed 8 years ago by scottmc

Can you try building cdrecord in Linux and see if it correctly detects it there? Note that this cdrecord is NOT the one that comes with most linux distros. http://cdrecord.berlios.de/private/cdrecord.html

comment:6 Changed 7 years ago by scottmc

This may or may not help, but can you try this build and see if anything has changed? http://haiku-files.org/files/optional-packages/cdrtools-3.01a06-x86-gcc2-2012-03-31.zip

comment:7 Changed 7 years ago by Disreali

Still not working. Thanks for the help.

comment:8 Changed 7 years ago by anevilyak

Please recheck with hrev44361.

comment:9 Changed 7 years ago by Disreali

Yay! That Fixed It!! Thanks

Welcome to the Haiku shell.

/boot/home 
> cdrecord -scanbus
Cdrecord-ProDVD-ProBD-Clone 3.01a07 (i586-pc-haiku) Copyright (C) 1995-2012 Joerg Schilling
Using libscg version 'schily-0.9'.
scsibus0:
        0,0,0     0) 'ATAPI   ' 'DVD A  DH16A1S  ' 'HA11' Removable CD-ROM
        0,1,0     1) *
        0,2,0     2) '' '' '' NON CCS Disk
        0,3,0     3) *
        0,4,0     4) *
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *
/boot/home 
> 

comment:10 Changed 7 years ago by anevilyak

Component: - GeneralApplications/Command Line Tools
Resolution: fixed
Status: newclosed

Thanks for confirming!

Note: See TracTickets for help on using tickets.