Opened 8 years ago

Closed 5 years ago

#7223 closed bug (fixed)

changing fonts could leave system unreadable

Reported by: scottmc Owned by: axeld
Priority: normal Milestone: R1/beta1
Component: Kits/Interface Kit Version: R1/Development
Keywords: Cc:
Blocked By: #3273 Blocking:
Has a Patch: no Platform: All

Description

I recently was testing out some fonts and switched one of the fonts to the one I was testing and it seems that the new font doesn't display correctly and seems to have wigged out many of the gui apps. I am not able to switch it back due to the font prefs app not displaying correctly (see attached image). Deleting the Font_Settings in /boot/home/config/settings/ didn't help. There should be a way to fall back to the default settings, but it's not clear to me and probably not clear to 90%+ of users what you should to to fall back to defaults (if it's even possible). Also it seems there's no "Component" avaiable on trac for "Preferences/Fonts".

Attachments (3)

defaultfont.png (58.6 KB) - added by scottmc 8 years ago.
How to change the font when I can't see anything?
tallwindow.png (44.0 KB) - added by scottmc 8 years ago.
When a bad font is installed Notifications Prefs app becomes a very tall window, perhaps even not having a bottom.
badfont.png (54.5 KB) - added by scottmc 8 years ago.

Download all attachments as: .zip

Change History (11)

Changed 8 years ago by scottmc

Attachment: defaultfont.png added

How to change the font when I can't see anything?

Changed 8 years ago by scottmc

Attachment: tallwindow.png added

When a bad font is installed Notifications Prefs app becomes a very tall window, perhaps even not having a bottom.

comment:1 Changed 8 years ago by scottmc

The tall window is similar to #3273, but I checked team monitor and it's showing up just fine.

Appearance prefs has no bottom. Backgrounds Pref has no bottom. CPU Frequency and DataTranslations do have a bottom but the text is not displaying correctly.

Changed 8 years ago by scottmc

Attachment: badfont.png added

comment:2 Changed 8 years ago by scottmc

The font that tripped this up was wqy-microhei: http://ports-space.haiku-files.org/media-fonts/ After rebooting the system was again readable and the wqy-microhei font was working and same with all the apps/prefs GUIs.

comment:3 Changed 8 years ago by anevilyak

Component: Preferences/AppearanceKits/Interface Kit
Owner: changed from darkwyrm to axeld

Sounds more like a bug in the font cache/font parsing then, assigning this to interface kit for now, though it might ultimately wind up being app_server.

comment:4 Changed 8 years ago by diver

I think you have to delete /boot/home/config/settings/system/app_server/appearance and reboot to restore default font settings. Though I agree that Font_Setting is more logical choice from the user POV.
Also app_server often lockups when non-default fonts are used, see #4258.

comment:5 Changed 5 years ago by pulkomandy

Blocked By: 3273 added

comment:6 Changed 5 years ago by pulkomandy

Does this still happen? I have been using non-default fonts for testing without noticing problems.

comment:7 Changed 5 years ago by diver

I'm unable to reproduce it after installing wqy-microhei package and setting it up in Appearance. Probably fixed?

comment:8 Changed 5 years ago by scottmc

Resolution: fixed
Status: newclosed

I haven't seen this happen in a long long time, so closing as probably fixed.

Note: See TracTickets for help on using tickets.