Opened 10 years ago

Closed 4 years ago

Last modified 4 years ago

#4258 closed bug (fixed)

Using new fonts crashes app_server ...

Reported by: herdemir Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: Cc: scorps@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I added some other fonts like Liberation Sans & co and some windows fonts using UserBuildConfig during build time. I can boot fine and use Haiku very well. But sometimes either choosing font of Terminal or loading a page on Firefox crashes the app_server. This happens frequently lately. Added stack trace and kernel stack trace of the thread. By the way I'm using Haiku natively.

Tested on hrev32446.

Attachments (2)

bt-report.jpg (317.3 KB) - added by herdemir 10 years ago.
KDL-bt-report.jpg (161.7 KB) - added by herdemir 10 years ago.

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by herdemir

Attachment: bt-report.jpg added

Changed 10 years ago by herdemir

Attachment: KDL-bt-report.jpg added

comment:1 Changed 9 years ago by diver

Can you still reproduce it? There were several updates to FreeType since you reported this bug. Thanks.

comment:2 Changed 9 years ago by diver

Version: R1/pre-alpha1R1/Development

Reproducible with Tahoma fonts in hrev38824.

comment:3 Changed 9 years ago by Michael S.

Cc: scorps@… added

comment:4 Changed 8 years ago by diver

This bug is no longer reproducible over here.

comment:5 Changed 8 years ago by stargatefan

I have a large font pakc for commercial art work, some of those fonts do trip up the server still. I will grab a few of the offenders and attach them to the ticket later.

comment:6 in reply to:  5 Changed 8 years ago by mmadia

Replying to stargatefan:

I have a large font pakc for commercial art work, some of those fonts do trip up the server still. I will grab a few of the offenders and attach them to the ticket later.

Even though it is for testing purposes, do not upload commercial software to this site.

... and don't provide download links either.

Last edited 8 years ago by mmadia (previous) (diff)

comment:7 Changed 5 years ago by pulkomandy

Any changes in the last 3 years here? Are there fonts still known to crash?

Even if you can't upload them for licensing reasons, at least provide the name of the offending fonts so we can keep track of the problem.

comment:8 Changed 4 years ago by Janus

Resolution: fixed
Status: newclosed

Working on FontBoy I had installed hundreds of fonts, I had never experience this. I close this ticket. Please reopen with the list of fonts if this still happen for you. Thanks.

Last edited 4 years ago by Janus (previous) (diff)
Note: See TracTickets for help on using tickets.