Opened 13 years ago

Closed 12 years ago

#73 closed bug (fixed)

libroot_build.so broken cross-compiling from Linux

Reported by: spock@… Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version:
Keywords: Cc: tomas.wilhelmsson@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description (last modified by bonefish)

The standard build (jam -q haiku-image) fails with:

.. SetType1 generated/objects/haiku/x86/release/add-ons/kernel/bus_managers/pci/pci Error: "generated/objects/haiku/x86/release/add-ons/kernel/bus_managers/pci/pci": No such file or directory.

when the code tree is located on a partition other than / (eg. /devel/os/haiku, /devel being a reiserfs filesystem). I tracked this problem down a little bit and found out that normalize_dir_path() called from add_dir_path() in src/build/libroot/fs.cpp fails to build an absolute path. When the code tree is moved to /, it works just fine.

Attachments (1)

fs.patch (1.0 KB) - added by jackburton 13 years ago.
Patch for fs.cpp which fixes the bug

Download all attachments as: .zip

Change History (11)

comment:1 Changed 13 years ago by bonefish

Summary: libroot_build.so broken cross-compiling from Linux libroot_build.so broken cross-compiling from Linux

comment:2 Changed 13 years ago by bonefish

Status: newassigned

comment:3 Changed 13 years ago by bonefish

The "break" when encountering "." or ".." definitely doesn't look right. The solution for mount points looks interesting. I'll look into that.

Changed 13 years ago by jackburton

Attachment: fs.patch added

Patch for fs.cpp which fixes the bug

comment:4 Changed 13 years ago by bonefish

* Bug 76 has been marked as a duplicate of this bug. *

comment:5 Changed 13 years ago by bonefish

Cc: tomas.wilhelmsson@… added

comment:6 Changed 13 years ago by bonefish

Fixed in revision 15726.

comment:7 Changed 13 years ago by bonefish

Resolution: fixed

comment:8 Changed 13 years ago by bonefish

Status: assignedclosed

comment:9 Changed 12 years ago by icepic

Platform: x86
Resolution: fixed
Status: closedreopened

I get the same effects on Linux now (checked out buildtools and haiku today, 2007-08-22): ... AddTargetVariableToScript1 generated/haiku.image-init-vars InitScript1 generated/haiku.image-make-dirs CreateContainerMakeDirectoriesScript1 generated/haiku.image-make-dirs ResComp1 generated/objects/haiku/x86/common/home-config-settings-printers-preview.rsrc rc: Error! unknown error: 80006003 (No such file or directory)

My haiku dir is at /local/haiku and my /local differs from / like this: /dev/sda3 6.3G 3.6G 2.5G 60% / /dev/hda1 151G 12G 138G 8% /local

I can't move the haiku stuff to /, and the "fix" that went in two years ago doesn't solve it for me.

comment:10 Changed 12 years ago by bonefish

Description: modified (diff)
Resolution: fixed
Status: reopenedclosed

Please don't hijack closed tickets. The original problem has been understood and fixed; this problem is unrelated. Please open a new ticket and attach the complete build output.

Note: See TracTickets for help on using tickets.