Opened 9 years ago

Closed 7 years ago

#7310 closed bug (fixed)

Optional packages: KeymapSwitcher doesn't work as intended

Reported by: MichaelPeppers Owned by: siarzhuk
Priority: normal Milestone: R1
Component: Applications Version: R1/Development
Keywords: optional package KeymapSwitcher Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev40756 gcc4hybrid, none of KeymapSwitcher's hotkeys work and, no matter how you change the current hotkey, as soon as the Deskbar loses focus the keymap is automatically switched to the first one of the list. This wouldn't be a big deal if the hotkeys worked, but since they don't, the program at its current state is unusable.

Also, its link in the menu is being created into "Desktop/applets" instead of "Desktop applets".

Change History (13)

in reply to:  description comment:1 by MichaelPeppers, 9 years ago

Replying to MichaelPeppers:

no matter how you change the current hotkey

Whoops, I meant keymap.

comment:2 by siarzhuk, 9 years ago

  1. To force hotkeys working just reboot the system or install correct (gcc4 or gcc2) version of KeymapSwitcher. How did you get it first time?
  1. It is intended, that current keymap is team(process)-sensitive. So if you change the focus from Deskbar to other window the current keymap must be changed to current one for that team(process). So the observed behavior is correct.

in reply to:  2 ; comment:3 by MichaelPeppers, 9 years ago

Replying to siarzhuk:

  1. To force hotkeys working just reboot the system or install correct (gcc4 or gcc2) version of KeymapSwitcher. How did you get it first time?

Didn't know that, I just rebooted and now it works. If you want to know how I installed it, I used installoptionalpackage.

Replying to siarzhuk:

  1. It is intended, that current keymap is team(process)-sensitive. So if you change the focus from Deskbar to other window the current keymap must be changed to current one for that team(process). So the observed behavior is correct.

And that is good, but changing the keymap by clicking on KeymapSwitcher or by using the right-click menu gives focus to the Deskbar, which is why any method of changing keymap other than hotkeys seems useless right now.

And... changing keymaps too much while in Pe crashed the Deskbar. Syslog needed?

in reply to:  3 ; comment:4 by siarzhuk, 9 years ago

Replying to MichaelPeppers:

Replying to siarzhuk:

  1. How did you get it first time?

If you want to know how I installed it, I used installoptionalpackage.

The version looking outdated - most of observed issues were already fixed. I thought that installoptionalpackage get the latest one. Are you using Alpha image or nightly builds?

Replying to siarzhuk:

  1. It is intended, that current keymap is team(process)-sensitive. So if you change the focus from Deskbar to other window the current keymap must be changed to current one for that team(process). So the observed behavior is correct.

And that is good, but changing the keymap by clicking on KeymapSwitcher or by using the right-click menu gives focus to the Deskbar, which is why any method of changing keymap other than hotkeys seems useless right now.

Yes, of course, I have understood why you decide that it not working. ;-) Probably it has no sense, but further improvements to this program has no sense too - this app lives just until the normal solution for Haiku will be implemented.

And... changing keymaps too much while in Pe crashed the Deskbar. Syslog needed?

I'm going to update this optional package soon - so there are no sense to test outdated version. ;-) Just wait or get the new version here right now:

http://sourceforge.net/projects/dotmatrix4beos/files/Haiku%20Keymap%20Switcher/1.2.6/

note that you need to use corresponding update-*.sh script to update your system on the fly. ;-) Just exploding zip onto /boot can send your input_server to KDL. So, please, use the update script.

in reply to:  4 comment:5 by MichaelPeppers, 9 years ago

Replying to siarzhuk:

The version looking outdated - most of observed issues were already fixed. I thought that installoptionalpackage get the latest one. Are you using Alpha image or nightly builds?

I thought so too. I'm using one of the latest nightlies (hrev40756)

Yes, of course, I have understood why you decide that it not working. ;-) Probably it has no sense, but further improvements to this program has no sense too - this app lives just until the normal solution for Haiku will be implemented.

Thanks for the explaination, I see. I'll wait for the Haiku keymap utility, then. =)

I'm going to update this optional package soon - so there are no sense to test outdated version. ;-) Just wait or get the new version here right now:

http://sourceforge.net/projects/dotmatrix4beos/files/Haiku%20Keymap%20Switcher/1.2.6/

note that you need to use corresponding update-*.sh script to update your system on the fly. ;-) Just exploding zip onto /boot can send your input_server to KDL. So, please, use the update script.

Thank you. Downloaded and installed. Nice script. =)

comment:6 by scottmc, 8 years ago

Owner: changed from nobody to siarzhuk
Status: newassigned

in reply to:  3 ; comment:7 by siarzhuk, 8 years ago

Replying to MichaelPeppers:

And... changing keymaps too much while in Pe crashed the Deskbar. Syslog needed?

Is it still observed with the latest versions (1.2.6.12)?

in reply to:  7 comment:8 by MichaelPeppers, 8 years ago

Replying to siarzhuk:

Replying to MichaelPeppers:

And... changing keymaps too much while in Pe crashed the Deskbar. Syslog needed?

Is it still observed with the latest versions (1.2.6.12)?

Will upgrade to a newer A3-rc later this evening, then I'll stress test and report back.

comment:9 by MichaelPeppers, 8 years ago

At first I thought not, then, when I was reporting back to this ticket, changing keymaps a last time (this time in Webpositive) lead to a silent crash of the Deskbar (unresponsive, leaf button disappeared), which also hanged the Tracker, leading me to an abrupt Ctrl-Alt-Del reboot.

Another couple of things, the replicant should have a fixed size or adapt to every keymap instead of adapting only to the first selected keymap, as some keymap names can get cropped because of that. (try setting "Italian" as the first one, "US-International" as the second one, install the replicant and switch to see what I mean) Also, "United Kingdom"'s keymap name should be "UK", not "Un".

I used the latest version of KeymapSwitcher on hrev42190-rc.

Last edited 8 years ago by MichaelPeppers (previous) (diff)

comment:10 by diver, 7 years ago

Component: - GeneralApplications
Keywords: KeymapSwitcher added; keymapswitcher removed

Works fine here, can you still reproduce it with a current nightly?

in reply to:  10 comment:11 by MichaelPeppers, 7 years ago

Replying to diver:

Works fine here, can you still reproduce it with a current nightly?

Will do ASAP

comment:12 by diver, 7 years ago

So?

in reply to:  9 comment:13 by siarzhuk, 7 years ago

Resolution: fixed
Status: assignedclosed

Replying to MichaelPeppers:

And that is good, but changing the keymap by clicking on KeymapSwitcher or by using the right-click menu gives focus to the Deskbar, which is why any method of changing keymap other than hotkeys seems useless right now.

Fixed in KeymapSwitcher 1.2.7.1

And... changing keymaps too much while in Pe crashed the Deskbar. Syslog needed?

Unfortunately, the keymap change event goes too long way (input filter -> Deskbar replicant -> overwriting ~/config/settings/Key_map file with new one -> forcing input_server to reload current keymap) so it is no wonder, that frequent change of keymap may crash somewhere. :-( I suspect we have to live with it.

Replying to MichaelPeppers:

Another couple of things, the replicant should have a fixed size or adapt to every keymap instead of adapting only to the first selected keymap, as some keymap names can get cropped because of that. (try setting "Italian" as the first one, "US-International" as the second one, install the replicant and switch to see what I mean)

Fixed in KeymapSwitcher 1.2.7.2 that comes in some days in the optional packages list.

Also, "United Kingdom"'s keymap name should be "UK", not "Un".

The 2-letters language codes are related to the name of keymap files, but the name of language. Current format of keymap file provide not so much useful information that can be used for this purposes.

Note: See TracTickets for help on using tickets.