Opened 8 years ago

Closed 8 years ago

#7317 closed bug (duplicate)

Haiku unable to set resolutions other than 640x480, Nvidia Geforce 6800

Reported by: lassiethebrave Owned by: rudolfc
Priority: normal Milestone: R1
Component: Drivers/Graphics/nVidia Version: R1/Development
Keywords: nvidia, geforce 6800, resolution Cc: lassiethebrave@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Haiku doesn't offer me any other options for resolution than 640x480 when running from disc or live cd.

Additionally if I (as was suggested to me on #haiku) remove (or move) the nvidia.accelerant file from it's location the system hangs on boot (after lighting up all the icons)

The Graphics card is a Nvidia GeForce 6800 and using the dvi or vga outputs produce the same results.

This bug affects both the alpha2 and the nightly build 40790.

I do not know what else to put here, so please ask and I will provide as much information as I can.

Attachments (3)

hwinfo.asc (3.1 KB) - added by lassiethebrave 8 years ago.
output of listdev
nvidia.10de_00c1_010000.0.log (49.6 KB) - added by lassiethebrave 8 years ago.
logfile as requested by diver (#haiku)
syslog (216.6 KB) - added by lassiethebrave 8 years ago.
syslog as requested by diver (#haiku)

Download all attachments as: .zip

Change History (10)

comment:1 Changed 8 years ago by anevilyak

Component: Preferences/ScreenDrivers/Graphics/nVidia
Owner: changed from axeld to rudolfc

Changed 8 years ago by lassiethebrave

Attachment: hwinfo.asc added

output of listdev

comment:2 Changed 8 years ago by lassiethebrave

Addendum, as I can't figure out howto add things in the original report...
If however I delete all files related to the nvidia driver all is well and the vesa driver is used, providing me with all the resolutions I could ask for!
I have also attached the output of listdev on the box in question if that helps in any way.

comment:3 Changed 8 years ago by lassiethebrave

Cc: lassiethebrave@… added

Changed 8 years ago by lassiethebrave

logfile as requested by diver (#haiku)

Changed 8 years ago by lassiethebrave

Attachment: syslog added

syslog as requested by diver (#haiku)

comment:4 Changed 8 years ago by MichaelPeppers

Check out bug #6716, I bet these two are the same.

Are you using a not-so-new monitor?

Last edited 8 years ago by MichaelPeppers (previous) (diff)

comment:5 in reply to:  4 Changed 8 years ago by lassiethebrave

Replying to MichaelPeppers:

Check out bug #6716, I bet these two are the same.

Are you using a not-so-new monitor?

Two not-so-new monitors actually...
It does indeed seem to be the same bug (not that I know anything about screens, drivers etc), perhaps somebody with powers to do such things could merge them (or I could attach my files to #6716 and this one could be closed, I have no idea how these things work)
I promise I'll search better next time!

comment:6 Changed 8 years ago by rudolfc

Hi there,

Indeed, this is a duplicate of #6716. Your screen at connector two reports a strange, rather lowres mode in the additional modelines. This is the place were newer ('normal') monitors reports their native resolution at least, while yours doesn't. The other screen (1600x1200) is reporting correctly and therefore if you would remove that other screen this one would work with the driver as expected.

Closing this bug. Keep monitoring the other one for extensions to the driver.

Bye!

Rudolf.

comment:7 Changed 8 years ago by rudolfc

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.