Opened 9 years ago

Closed 9 years ago

#7364 closed bug (fixed)

Recreating accounts after updating Haiku

Reported by: humdinger Owned by: czeidler
Priority: normal Milestone: R1
Component: Preferences/Mail Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev40924.

As taos mentioned in #7267, email accounts have to be recreated after updating to a newer Haiku revision. I usually boot a new image from USB and install it over an existing Haiku installation on HD, thereby keeping all settings.

While the E-Mail prefs still show my two accounts, selecting their incoming or outgoing settings shows this:

E-Mail prefs

Maybe related: The MAIL:account attribute seems to change with every updated revision. It's also not readable, as it used to be, when it used the mail account name, see:

correct file...

These are all mails from my "Humdinger" account, the last one after a Haiku update.

Attachments (2)

accounts.png (15.9 KB ) - added by humdinger 9 years ago.
E-Mail prefs
different-account-names.png (13.9 KB ) - added by humdinger 9 years ago.
correct file…

Download all attachments as: .zip

Change History (10)

by humdinger, 9 years ago

Attachment: accounts.png added

E-Mail prefs

by humdinger, 9 years ago

Attachment: different-account-names.png added

correct file...

comment:1 by taos, 9 years ago

E-mail filters also disappear from account settings after upgrading.

comment:2 by taos, 9 years ago

Attribute type of MAIL:account used to be CSTR but is now LONG?

comment:3 by czeidler, 9 years ago

The first part should be fixed now hrev40943.

Yes MAIL:account is an int id now. To be exact its the creation time. The problem is that the account name can change or two accounts could have the same name. In case of changing the account name all already fetched mails have the wrong account. Any suggestions?, should I just remove the account attribute from the mime type. I think its quite useful to keep the attribute to see the origin of the mail but I don't know how to handle account name changes. There are two solutions:

  • run over all mails and update the account string
  • hack tracker to show the account name dynamically depending on the account id

I prefer the second solution since it can also combined with the display of mail status icons...

comment:4 by humdinger, 9 years ago

The first part should be fixed now hrev40943.

Can't confirm the fix. After updating to hrev40962 (with Installer copying onto an existing installation, thereby keeping the Mail settings) I still saw the error shown in the above screenshot.

comment:5 by humdinger, 9 years ago

WRT to the MAIL:account attribute: How about taking the account's email address domain, i.e. what's to the right of the "@"? This should stay the same for an account even if you change its name.

ETA: what to do if you have more than one account at the same email service?

Last edited 9 years ago by humdinger (previous) (diff)

comment:6 by czeidler, 9 years ago

Ok, you have to create the account after the last changes, did you? The add-on path was saved as an entry_ref but this is just the device id, the directory id and the file name. The id's can change when reinstalling Haiku so I store the path name now. Actually, I should just save the file name and lookup for the add-on in the add-on dir...

For the account field: Maybe the complete mail address in a MAIL:address attribute would do it?

in reply to:  4 comment:7 by taos, 9 years ago

The first part should be fixed now hrev40943.

Can't confirm the fix. After updating to hrev40962 (with Installer copying onto an existing installation, thereby keeping the Mail settings) I still saw the error shown in the above screenshot.

I can confirm the fix. I first updated to hrev40950 and had to recreate my accounts (I suppose that's the moment the add-on path was saved). After I updated to hrev40965 my accounts are still there and the Incoming and Outgoing settings (as well as e-mail filters) are displayed as they should. Thanks!

comment:8 by czeidler, 9 years ago

Resolution: fixed
Status: newclosed

Fixed.

Note: See TracTickets for help on using tickets.