Opened 8 years ago

Closed 8 years ago

#7365 closed bug (fixed)

mail_daemon crashing while creating accounts

Reported by: humdinger Owned by: czeidler
Priority: normal Milestone: R1
Component: Servers/mail_daemon Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev40924.

When creating new mail accounts, sometimes mail_daemon crashes. Mostly, after clicking "Apply" when your done with the "Outgoing" settings. Backtrace:

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Thread 432 caused an exception: Segment violation
[...]
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/system/servers/mail_daemon (426) thread w>Mail Status (432)]
0x003d511c in BMessage::_FindField () from /boot/system/lib/libbe.so
(gdb) bt
#0  0x003d511c in BMessage::_FindField () from /boot/system/lib/libbe.so
#1  0x003d6205 in BMessage::FindData () from /boot/system/lib/libbe.so
#2  0x003d6406 in BMessage::FindRef () from /boot/system/lib/libbe.so
#3  0x003d648f in BMessage::FindRef () from /boot/system/lib/libbe.so
#4  0x0059f2be in AddonSettings::Load () from /boot/system/lib/libmail.so
#5  0x005a0ae0 in MailAddonSettings::Load () from /boot/system/lib/libmail.so
#6  0x005a0cd5 in BMailAccountSettings::Reload ()
   from /boot/system/lib/libmail.so
#7  0x005a0e6e in BMailAccountSettings::BMailAccountSettings ()
   from /boot/system/lib/libmail.so
#8  0x005a0fd3 in BMailAccounts::BMailAccounts ()
   from /boot/system/lib/libmail.so
#9  0x00217b80 in MailStatusWindow::_CheckChains ()
#10 0x00217d03 in MailStatusWindow::MessageReceived ()
#11 0x003d1748 in BLooper::DispatchMessage () from /boot/system/lib/libbe.so
#12 0x0049518c in BWindow::DispatchMessage () from /boot/system/lib/libbe.so
#13 0x00490a91 in BWindow::task_looper () from /boot/system/lib/libbe.so
#14 0x003d2faa in BLooper::_task0_ () from /boot/system/lib/libbe.so
#15 0x00248c3d in thread_entry () from /boot/system/lib/libroot.so
#16 0x70080fec in ?? ()
(gdb) 

I also got a different one, I think, when applying settings in the second preference tab dealing with fetching-mail-intervalls etc.:

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Thread 125 called debugger(): sb
[...]
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/system/servers/mail_daemon -E (125) thread mail_daemon (125)]
0xffff0114 in ?? ()
(gdb) bt
#0  0xffff0114 in ?? ()
#1  0x00244d8b in debugger () from /boot/system/lib/libroot.so
#2  0x0024f16f in __assert_fail () from /boot/system/lib/libroot.so
#3  0x002bb920 in BPrivate::processHeap::free ()
   from /boot/system/lib/libroot.so
#4  0x002bd2c1 in free () from /boot/system/lib/libroot.so
#5  0x01bc3ad3 in CRYPTO_free () from /boot/common/lib/libcrypto.so.1.0.0
#6  0xffffffff in ?? ()
#7  0x01bc3aaa in CRYPTO_free () from /boot/common/lib/libcrypto.so.1.0.0
#8  0x18061ef8 in ?? ()
#9  0x01c68c7b in X509_VERIFY_PARAM_free ()
   from /boot/common/lib/libcrypto.so.1.0.0
#10 0x7ffee838 in ?? ()
#11 0x01c68c1a in X509_VERIFY_PARAM_free ()
   from /boot/common/lib/libcrypto.so.1.0.0
#12 0x18061e58 in ?? ()
#13 0x01d00f33 in SSL_CTX_free () from /boot/common/lib/libssl.so.1.0.0
#14 0x7fffffff in ?? ()
#15 0x01d00eea in SSL_CTX_free () from /boot/common/lib/libssl.so.1.0.0
#16 0x18061470 in ?? ()
#17 0x01b83f2b in POP3Protocol::Disconnect ()
   from /boot/system/add-ons/mail_daemon/inbound_protocols/POP3
#18 0x01b849d9 in POP3Protocol::~POP3Protocol ()
   from /boot/system/add-ons/mail_daemon/inbound_protocols/POP3
---Type <return> to continue, or q <return> to quit---
#19 0x002121bb in MailDaemonApp::_RemoveAccount ()
#20 0x0021257c in MailDaemonApp::_ReloadAccounts ()
#21 0x00214838 in MailDaemonApp::MessageReceived ()
#22 0x003d1748 in BLooper::DispatchMessage () from /boot/system/lib/libbe.so
#23 0x003c899b in BApplication::DispatchMessage ()
   from /boot/system/lib/libbe.so
#24 0x003d3284 in BLooper::task_looper () from /boot/system/lib/libbe.so
#25 0x003c8e74 in BApplication::Run () from /boot/system/lib/libbe.so
#26 0x0021618e in main ()
(gdb)

Change History (3)

comment:1 Changed 8 years ago by czeidler

Could you check if hrev40955 fixed it? Not sure if there is also another problem. I'm using vmware at the moment and can't reproduce it...

comment:2 Changed 8 years ago by humdinger

Seems to be fixed. At least it didn't crash after recreating 3 pop3 accounts after updating to hrev40962. Thanks!

comment:3 Changed 8 years ago by czeidler

Resolution: fixed
Status: newclosed

Cool thanks for testing!

Note: See TracTickets for help on using tickets.