Opened 9 years ago

Closed 8 years ago

#7375 closed bug (fixed)

Tracker still uses E-mail attribute "Thread" but mails are stored without MAIL:thread

Reported by: taos Owned by: czeidler
Priority: normal Milestone: R1
Component: Add-Ons/Tracker Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #7383
Has a Patch: no Platform: All

Description

Using hrev40950 (gcc2 hybrid).

In Tracker windows It is possible to choose to display the E-mail attribute "Thread". However, mails are now created without the corresponding attribute MAIL:thread. Consequently, if you choose to show "Thread" there is no information that can be displayed. The same is true for the attribute "Name": MAIL:name seems no longer in use.

Change History (6)

comment:1 by axeld, 9 years ago

I'm not sure what MAIL:name was even used for (not sure if it's a compatibility problem to leave it out), but MAIL:thread is definitely a desired attribute with how Tracker currently works, as it allows grouping over threads.

in reply to:  1 comment:2 by bonefish, 9 years ago

Replying to axeld:

I'm not sure what MAIL:name was even used for (not sure if it's a compatibility problem to leave it out),

I believe MAIL:name contains the name of the From: or To: field (whichever applies), falling back to the address, if it doesn't have a name. So it's essentially a shorter, easier to read version of the header field and therefore what people who like easier to read prefer to display. If the attribute isn't created anymore, I would consider that a bug.

comment:3 by anevilyak, 8 years ago

Blocking: 7383 added

(In #7383) Duplicate of #7375.

comment:4 by czeidler, 8 years ago

Owner: changed from nobody to czeidler
Status: newassigned

The file name attribute already remove all the Re:, Fwd: stuff. Did the thread attribute something else? I admit, the name attribute is not very intuitive to sort mail by thread but its save some attribute space. Thoughts?

The MAIL:name attribute seems to be quite useful should I add it?

comment:5 by jonas.kirilla, 8 years ago

The filename has a timestamp and a name in it. I prefer to have "When" and "To"/"From" in their own columns. I want my "Thread" column to contain only the Subject, in its distilled form.

comment:6 by czeidler, 8 years ago

Resolution: fixed
Status: assignedclosed

fixed in hrev41062

Note: See TracTickets for help on using tickets.