Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#7379 closed bug (duplicate)

BootManager does not work as expected.

Reported by: bbjimmy Owned by: laplace
Priority: normal Milestone: R1
Component: Applications/BootManager Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

BootManager needs to allow the user to select partitions on more than one disk drive to boot from.

A typical installation:

Windows is installed on the first hard disk.

Haiku is installed on the second rard disk.

BootManager is useless ibn this case. It will not allow the user to select to boot either Windows or haiku as it will only list the partitions on one hard disk.

Change History (3)

comment:1 by mmadia, 11 years ago

Resolution: duplicate
Status: newclosed
Version: R1/alpha2R1/Development

Duplicate of #3545. (that ticket is listed under system/kernel, as that's where most of the work needs to be done.)

comment:2 by bbjimmy, 11 years ago

#3545 is marked as an enhancement. This is not an enhancement. It is enhancing the system, it is corecting a missing feature and bringing Haiku's BootManager up to where the BeOS hrev5 Bootman was. This is a missing feature IE bug, not an enhancement.

comment:3 by axeld, 11 years ago

Adding a missing feature is called an enhancement. Even if it makes the BootManager unusable for you, it will still work for most of the users -- and you are free to choose any other boot manager to support your specific setup; it's not that you are forced to use Haiku's BootManager. It's quite a bit of work to support this, and so far, no one needed it as much to actually spend any effort on it.

Besides that, patches are always welcome :-)

Note: See TracTickets for help on using tickets.