Opened 11 years ago

Closed 11 years ago

#7380 closed bug (duplicate)

Wifi - Ping is OK but downloads dies

Reported by: deejam Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet/Wireless Version: R1/Development
Keywords: Cc:
Blocked By: #7346 Blocking:
Platform: All

Description

I am connected to a non-encrypted 802.11G wifi network. I can stay connected for hours without any ping packages being lost. WebPositive will stop receiving data every 1-5 minutes. File downloads will fail after a couple of minutes. The same happens if I try to download a file using wget. Restarting WebPositive temporary solves the problem. Same with wget.

Vision can connect. If I am fast enough, I will be able to join a channel but I will not be able to send or receive anything. I will not be disconnected.

Works without any problems on a wired connection. Wifi works in WIndows on this laptop and also on Windows on another computer.

When connected with wifi, the syslogs shows reccuring DHCP_RELEASE etc, which is not happeining with wired network.

KERN: /dev/net/atheroswifi/0: media change, media 0x8300ae quality 1000 speed 10000000
DAEMON 'DHCP': Send DHCP_RELEASE to 10.10.20.1:67 on /dev/net/atheroswifi/0
DAEMON 'DHCP': Send DHCP_DISCOVER to 255.255.255.255:67 on /dev/net/atheroswifi/0
DAEMON 'DHCP': Timeout shift for /dev/net/atheroswifi/0: 4 secs (try 0)
DAEMON 'DHCP': Send DHCP_DISCOVER to 255.255.255.255:67 on /dev/net/atheroswifi/0
DAEMON 'DHCP': Received DHCP_OFFER from 10.10.20.1 for /dev/net/atheroswifi/0
DAEMON 'DHCP':   your_address: 10.10.20.112
DAEMON 'DHCP':   server: 10.10.20.1
DAEMON 'DHCP':   lease time: 86400 seconds
DAEMON 'DHCP':   renewal time: 43200 seconds
DAEMON 'DHCP':   rebinding time: 75600 seconds
DAEMON 'DHCP':   subnet: 255.255.255.0
DAEMON 'DHCP':   broadcast: 10.10.20.255
DAEMON 'DHCP':   nameserver[0]: 10.10.20.1
DAEMON 'DHCP':   gateway: 10.10.20.1
DAEMON 'DHCP': Send DHCP_REQUEST to 255.255.255.255:67 on /dev/net/atheroswifi/0
DAEMON 'DHCP': Received DHCP_OFFER from 10.10.20.1 for /dev/net/atheroswifi/0
DAEMON 'DHCP': Received DHCP_ACK from 10.10.20.1 for /dev/net/atheroswifi/0
DAEMON 'DHCP':   server: 10.10.20.1
DAEMON 'DHCP':   lease time: 86400 seconds
DAEMON 'DHCP':   renewal time: 43200 seconds
DAEMON 'DHCP':   rebinding time: 75600 seconds
DAEMON 'DHCP':   subnet: 255.255.255.0
DAEMON 'DHCP':   broadcast: 10.10.20.255
DAEMON 'DHCP':   nameserver[0]: 10.10.20.1
DAEMON 'DHCP':   gateway: 10.10.20.1
DAEMON 'DHCP': DHCP for /dev/net/atheroswifi/0, status: No error

The log above will repeat over and over again while connected with wifi.

hrev40991 GCC2 Hybrid.

Hardware: IBM T41 Wifi: Atheros AR5212 Wired: Intel 82540EP

Change History (4)

comment:1 by deejam, 11 years ago

I've noticed that the wifi network works better and better after a time. Now, with an uptime of 2,5 hours, I've been able to use WebPositive for an hour and I can even join #haiku on IRC.

After a reboot, the network dies after less than a minuted. After a while, it works a couple of minutes, then 5 and now it seems to work (for how long, I don't know). The DHCP messages has not showed up in syslog for a while:

Welcome to the Haiku shell.

~> tail -f /boot/common/var/log/syslog
KERN: [net/atheroswifi/0] [00:17:31:d5:a8:1f] erp change: was 0x104, now 0x100
KERN: [net/atheroswifi/0] [00:17:31:d5:a8:1f] erp change: was 0x100, now 0x104
KERN: [net/atheroswifi/0] [00:17:31:d5:a8:1f] erp change: was 0x104, now 0x100
KERN: [net/atheroswifi/0] [00:17:31:d5:a8:1f] erp change: was 0x100, now 0x104
KERN: [net/atheroswifi/0] [00:17:31:d5:a8:1f] erp change: was 0x104, now 0x100
KERN: module: Search for network/protocols/ipv6/v1 failed.
KERN: [net/atheroswifi/0] [00:17:31:d5:a8:1f] erp change: was 0x100, now 0x104
KERN: [net/atheroswifi/0] [00:17:31:d5:a8:1f] erp change: was 0x104, now 0x100
KERN: module: Search for network/protocols/ipv6/v1 failed.
USER: Image /boot/system/apps/Terminal (address 258aec) requested catalog with mimetype x-vnd.Haiku-Terminal
KERN: Last message repeated 3 times.
KERN: module: Search for network/protocols/ipv6/v1 failed.
KERN: Last message repeated 2 times.
KERN: module: Search for network/protocols/ipv6/v1 failed.
KERN: Last message repeated 5 times.
KERN: module: Search for network/protocols/ipv6/v1 failed.
Last message repeated 1 time
KERN: Last message repeated 13 times.
KERN: Last message repeated 2 times.
KERN: Last message repeated 5 times.
KERN: Last message repeated 3 times.
Last message repeated 1 time
KERN: module: Search for network/protocols/ipv6/v1 failed.
Last message repeated 1 time
KERN: [net/atheroswifi/0] [00:17:31:d5:a8:1f] erp change: was 0x100, now 0x104
KERN: [net/atheroswifi/0] [00:17:31:d5:a8:1f] erp change: was 0x104, now 0x100
KERN: module: Search for network/protocols/ipv6/v1 failed.
KERN: Last message repeated 4 times.
KERN: Last message repeated 7 times.
KERN: Last message repeated 3 times.
KERN: Last message repeated 2 times.
KERN: [net/atheroswifi/0] [00:17:31:d5:a8:1f] erp change: was 0x100, now 0x104
KERN: [net/atheroswifi/0] [00:17:31:d5:a8:1f] erp change: was 0x104, now 0x100
USER: Image /boot/system/apps/AboutSystem (address 221304) requested catalog with mimetype x-vnd.Haiku-About
KERN: [net/atheroswifi/0] [00:17:31:d5:a8:1f] erp change: was 0x100, now 0x104
KERN: [net/atheroswifi/0] [00:17:31:d5:a8:1f] erp change: was 0x104, now 0x100
KERN: module: Search for network/protocols/ipv6/v1 failed.
KERN: [net/atheroswifi/0] [00:17:31:d5:a8:1f] erp change: was 0x100, now 0x104
KERN: [net/atheroswifi/0] [00:17:31:d5:a8:1f] erp change: was 0x104, now 0x100

comment:2 by deejam, 11 years ago

I can confirm that the problem seems to be DHCP related.

It stoped working in the middle of receiving a web page. I looked at my syslog (I had tail -f running) and there it was, the first DHCP_RELEASE/RENEW since the last time WebPositive died. I can also confirm that I cannot send or receive in Vision.

I seem to get new IPs for each renew. And for each renew I need to restart WebPositive or reconnect Vision.

KERN: /dev/net/atheroswifi/0: media change, media 0x8300af quality 1000 speed 10000000
DAEMON 'DHCP': Send DHCP_RELEASE to 10.10.20.1:67 on /dev/net/atheroswifi/0
DAEMON 'DHCP': Send DHCP_DISCOVER to 255.255.255.255:67 on /dev/net/atheroswifi/0
DAEMON 'DHCP': Timeout shift for /dev/net/atheroswifi/0: 4 secs (try 0)
DAEMON 'DHCP': Send DHCP_DISCOVER to 255.255.255.255:67 on /dev/net/atheroswifi/0
KERN: /dev/net/atheroswifi/0: media change, media 0x8300ae quality 1000 speed 10000000
DAEMON 'DHCP': Received DHCP_OFFER from 10.10.20.1 for /dev/net/atheroswifi/0
DAEMON 'DHCP':   your_address: 10.10.20.116
DAEMON 'DHCP':   server: 10.10.20.1
DAEMON 'DHCP':   lease time: 86400 seconds
DAEMON 'DHCP':   renewal time: 43200 seconds
DAEMON 'DHCP':   rebinding time: 75600 seconds
DAEMON 'DHCP':   subnet: 255.255.255.0
DAEMON 'DHCP':   broadcast: 10.10.20.255
DAEMON 'DHCP':   nameserver[0]: 10.10.20.1
DAEMON 'DHCP':   gateway: 10.10.20.1
DAEMON 'DHCP': Send DHCP_REQUEST to 255.255.255.255:67 on /dev/net/atheroswifi/0
DAEMON 'DHCP': Received DHCP_OFFER from 10.10.20.1 for /dev/net/atheroswifi/0
DAEMON 'DHCP': Received DHCP_ACK from 10.10.20.1 for /dev/net/atheroswifi/0
DAEMON 'DHCP':   server: 10.10.20.1
DAEMON 'DHCP':   lease time: 86400 seconds
DAEMON 'DHCP':   renewal time: 43200 seconds
DAEMON 'DHCP':   rebinding time: 75600 seconds
DAEMON 'DHCP':   subnet: 255.255.255.0
DAEMON 'DHCP':   broadcast: 10.10.20.255
DAEMON 'DHCP':   nameserver[0]: 10.10.20.1
DAEMON 'DHCP':   gateway: 10.10.20.1
DAEMON 'DHCP': DHCP for /dev/net/atheroswifi/0, status: No error
DAEMON 'DHCP': Send DHCP_RELEASE to 10.10.20.1:67 on /dev/net/atheroswifi/0
DAEMON 'DHCP': Send DHCP_DISCOVER to 255.255.255.255:67 on /dev/net/atheroswifi/0
DAEMON 'DHCP': Received DHCP_OFFER from 10.10.20.1 for /dev/net/atheroswifi/0
DAEMON 'DHCP':   your_address: 10.10.20.116
DAEMON 'DHCP':   server: 10.10.20.1
DAEMON 'DHCP':   lease time: 86400 seconds
DAEMON 'DHCP':   renewal time: 43200 seconds
DAEMON 'DHCP':   rebinding time: 75600 seconds
DAEMON 'DHCP':   subnet: 255.255.255.0
DAEMON 'DHCP':   broadcast: 10.10.20.255
DAEMON 'DHCP':   nameserver[0]: 10.10.20.1
DAEMON 'DHCP':   gateway: 10.10.20.1
DAEMON 'DHCP': Send DHCP_REQUEST to 255.255.255.255:67 on /dev/net/atheroswifi/0
DAEMON 'DHCP': Received DHCP_ACK from 10.10.20.1 for /dev/net/atheroswifi/0
DAEMON 'DHCP':   server: 10.10.20.1
DAEMON 'DHCP':   lease time: 86400 seconds
DAEMON 'DHCP':   renewal time: 43200 seconds
DAEMON 'DHCP':   rebinding time: 75600 seconds
DAEMON 'DHCP':   subnet: 255.255.255.0
DAEMON 'DHCP':   broadcast: 10.10.20.255
DAEMON 'DHCP':   nameserver[0]: 10.10.20.1
DAEMON 'DHCP':   gateway: 10.10.20.1
DAEMON 'DHCP': DHCP for /dev/net/atheroswifi/0, status: No error
KERN: runtime_loader: /boot/common/lib/libxml2.so.2.7.8: No version information available (required by /boot/apps/WebPositive/lib/libwebcore.so)
KERN: Last message repeated 2 times.
KERN: module: Search for network/protocols/ipv6/v1 failed.
Last message repeated 2 times
KERN: [net/atheroswifi/0] [00:17:31:d5:a8:1f] erp change: was 0x100, now 0x104
KERN: [net/atheroswifi/0] [00:17:31:d5:a8:1f] erp change: was 0x104, now 0x100
KERN: /dev/net/atheroswifi/0: media change, media 0x8300af quality 1000 speed 10000000
DAEMON 'DHCP': Send DHCP_RELEASE to 10.10.20.1:67 on /dev/net/atheroswifi/0
DAEMON 'DHCP': Send DHCP_DISCOVER to 255.255.255.255:67 on /dev/net/atheroswifi/0
DAEMON 'DHCP': Timeout shift for /dev/net/atheroswifi/0: 4 secs (try 0)
DAEMON 'DHCP': Send DHCP_DISCOVER to 255.255.255.255:67 on /dev/net/atheroswifi/0
DAEMON 'DHCP': Received DHCP_OFFER from 10.10.20.1 for /dev/net/atheroswifi/0
DAEMON 'DHCP':   your_address: 10.10.20.117
DAEMON 'DHCP':   server: 10.10.20.1
DAEMON 'DHCP':   lease time: 86400 seconds
DAEMON 'DHCP':   renewal time: 43200 seconds
DAEMON 'DHCP':   rebinding time: 75600 seconds
DAEMON 'DHCP':   subnet: 255.255.255.0
DAEMON 'DHCP':   broadcast: 10.10.20.255
DAEMON 'DHCP':   nameserver[0]: 10.10.20.1
DAEMON 'DHCP':   gateway: 10.10.20.1
DAEMON 'DHCP': Send DHCP_REQUEST to 255.255.255.255:67 on /dev/net/atheroswifi/0
DAEMON 'DHCP': Received DHCP_OFFER from 10.10.20.1 for /dev/net/atheroswifi/0
DAEMON 'DHCP': Received DHCP_ACK from 10.10.20.1 for /dev/net/atheroswifi/0
DAEMON 'DHCP':   server: 10.10.20.1
DAEMON 'DHCP':   lease time: 86400 seconds
DAEMON 'DHCP':   renewal time: 43200 seconds
DAEMON 'DHCP':   rebinding time: 75600 seconds
DAEMON 'DHCP':   subnet: 255.255.255.0
DAEMON 'DHCP':   broadcast: 10.10.20.255
DAEMON 'DHCP':   nameserver[0]: 10.10.20.1
DAEMON 'DHCP':   gateway: 10.10.20.1
DAEMON 'DHCP': DHCP for /dev/net/atheroswifi/0, status: No error
KERN: runtime_loader: /boot/common/lib/libxml2.so.2.7.8: No version information available (required by /boot/apps/WebPositive/lib/libwebcore.so)
KERN: Last message repeated 2 times.
KERN: module: Search for network/protocols/ipv6/v1 failed.

Each KERN: runtime_loader: /boot/common/lib/libxml2.so.2.7.8: No version information available (required by /boot/apps/WebPositive/lib/libwebcore.so) is WebPositive being restarted.

I don't think I get new IPs using wired network or thru wifi in Windows. I can test that tomorrow.

comment:3 by deejam, 11 years ago

This looks to be the same problem as described in #7346. The router is running DD-WRT v24-sp2.

comment:4 by anevilyak, 11 years ago

Blocked By: 7346 added
Resolution: duplicate
Status: newclosed

Indeed the same problem, closing as a duplicate.

Note: See TracTickets for help on using tickets.